Showing results for 
Search instead for 
Did you mean: 

Project can not be oppened anymore after being deleted from project explorer view

Associate III

I have spent some weeks working on a firmware project. I had other projects on this tab that where clossed. So, if needed I can open the file and Iook for what I need from them. 

Last time I compiled the project. No errors. No warnings. A bit time later I deleted the projects I have having there without removing them from workspace folder in my hard disk unit. So, project explorer tab (CubeIDE) gets empty.

When I tried to open the project, process dialog shows me sometimes the message: project can not be imported because it is already opened at workspace. 

I need help for solving this and for continue working on that project. What is happening to this environment? 

I tried the whole list of ways for opening a project: double click over the project file (nothing is happening), importing from file system, importing existing projects from workspace (with error message), open project from file system (nothing happens), etc..  

this has non sense! It seems a bug.

Anyways I would like to work normally. If someone could give me ideas in order to find the problem cause and to find the solution it will be great. 


Thanks for your time. 

ST Employee

Hello @genisuvi ,

Could you, please, provide which STM32CubeIDE version , MCU and firmware package used for the project.



Associate III

Hi, Rim. 

version: 1.12.1

Mcu: stm32f207zg

Double click over project icon does not open anything and no message is launched. Click action is ignored. Same is happening when open project from file system option. 



So I tried with importing a project: It also is ignored.

Hence, here I tried another thing: to create a folder and trying to import with "copy project files into workspace" option. So "tachan", it works. 

I don't understand why the only way for opening this project is doing this "trick". This doesn't happen with the other projects I done with same package and for same mcu). 

I'm worried for doing this way because the folder should be synchronised with a remote folder on git (the other projects has been under control version the same way, but they never give me this issue). And now I'm forced to work with a "copy" of the original folder that is put into another folder in order to open it. The only way now is to import copying it to workspace where it originally was. So I'm forced to move it to another folder. It sounds like a mess!