cancel
Showing results for 
Search instead for 
Did you mean: 

Power Regulator Voltage scaling and SysClock issue

HDesa.1
Associate III

Hello,

I am using STM32H755 microcontroller and STM32CubeIDE V1.13.0 for my development.

I am not able to set the clock frequency to 480MHz. Whenever I do so, I receive power regulator voltage scaling error. (Shared in the attachment).

The product revision used by me is rev.V as no option to change to rev.Y is available. I also tried changing the SupplySource option but it didn't work.

The RCC parameter works only when the D1CPRE is set to 240MHz. And my requirement is 480MHz.

Is there any solution to run the microcontroller at 480MHz.

- Regards

Hrishikesh

1 ACCEPTED SOLUTION

Accepted Solutions
SofLit
ST Employee

Hello,

I looked at your ioc file and it seems you selected an "industrial temperature range" device at the beginning in CubeMx:

SofLit_1-1711210818289.png

According to the datasheet STM32H755xxx3 sales types are "industrial temperature range" or "extended temperature range" devices and the voltage regulator output can be set only to VOS2 or VOS3 in Run mode

SofLit_0-1711210758799.png

Datasheet page 252:

SofLit_2-1711211135282.png

So I don't know if your device is really the industrial version or not. You need to confirm.

Otherwise, you can select STM32H755xxx6 for "regular" devices with which you can reach 480MHz @VOS0.

So it's a normal behavior from CubeMx not a bug.

To give better visibility on the answered topics, please click on "Accept as Solution" on the reply which solved your issue or answered your question.

View solution in original post

6 REPLIES 6
SofLit
ST Employee

Hello,

You need to set the Voltage Scale to 0 at 480MHz only in LDO mode:

SofLit_0-1711026576846.png

 

To give better visibility on the answered topics, please click on "Accept as Solution" on the reply which solved your issue or answered your question.

Hello,

I had already looked into your suggestion previously. There is no option to select Voltage Scale as 0.

This is the error which I am getting.

HDesa1_0-1711169978056.png

What configuration am I missing?

Please share your ioc file

To give better visibility on the answered topics, please click on "Accept as Solution" on the reply which solved your issue or answered your question.

Please find in the attachment. I am using STM32CubeIDE version 1.13.0. If that affects

SofLit
ST Employee

Hello,

I looked at your ioc file and it seems you selected an "industrial temperature range" device at the beginning in CubeMx:

SofLit_1-1711210818289.png

According to the datasheet STM32H755xxx3 sales types are "industrial temperature range" or "extended temperature range" devices and the voltage regulator output can be set only to VOS2 or VOS3 in Run mode

SofLit_0-1711210758799.png

Datasheet page 252:

SofLit_2-1711211135282.png

So I don't know if your device is really the industrial version or not. You need to confirm.

Otherwise, you can select STM32H755xxx6 for "regular" devices with which you can reach 480MHz @VOS0.

So it's a normal behavior from CubeMx not a bug.

To give better visibility on the answered topics, please click on "Accept as Solution" on the reply which solved your issue or answered your question.

Hi,

Thank you so much for the help. I have verified my microcontroller. It is of STM32H755xxx6 version. Just on input from your side. Is it possible to change the controller type in the existing .ioc file or do I need to create a new .ioc file?

- Regards