Showing results for 
Search instead for 
Did you mean: 

myST button refuses or can't connect it worked 5/13 but not since


I started a new project 5/14 and it requires me to login using the myST button. For two days it refuses to connect. I am on a hardwired internet connection in a small two person company so there it no "IT" guy to check with.The advise given on this board does not change anything.  It worked on a different project 5/13

I'm thinking I have to re-install CUBE ??? That shouldn't be necessary everytime you change targets.

Chief II

>That shouldn't be necessary everytime you change targets

No, definitely. 

I use IDE 1.13.1 (on Linux) and 1.14.1 on Win 10. No problems so far, and more than 2 projects..


(just a part of all..)

So try: look here in forum about the actual problems with STM's awesome login, and the problems many people have now. (and check your rights/firwall settings/try VPN/ask google or AI ...)

If you feel a post has answered your question, please click "Accept as Solution".
ST Employee

Hello @madmike 

First let me thank you for posting.

I need to ask if you are using some sort of proxy to connect.
If it's the case, let's start by configuring STM32CubeIDE network connection settings.
Check this article for more details: How to set the network connection parameters for S... - STMicroelectronics Community


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.