Showing results for 
Search instead for 
Did you mean: 

How to Program and Debug micro STM3203

Associate II


I developed a boiard with micro STM32F030C8T6TR. But when I try to create a software in STMcubeMx Build and Debug. I can always  build succesfully my project, but When I try to Flash and Debug STcubemxIDE  open a popup with wrote, as following reported: 

Target connection failed



Target no device found

Error in initializing ST-LINK device.
Reason: No device found on target.



I'm usinf STM32 LINK v2 Debugger, with SWD I respected pinout connection. Following, microprocessor section, taken on the schematics:


And the Debug connector schematics


SomeBody Can help me to understand Why I cannot Flash and Debug, receving error messsage.



Chief II

Your schematics is buggy need connet VSSA and VDDA

But I don't need to use Analog, then VSSA and VDDA are not mandatory.

Chief II

MCU isnt analog as you mean, for example ADC part power on reset or clock oscilator is powered from "analog" as you connect now your MCU is dead

Associate II

Ok I tried to connect both of VDDA and VSSA, Can I connet them to VDD e GND? SWD Debug Peripheral need VSSA and VDDA?

Another question NRST need pull-up Resistor?


Open Nucleo 030 schematics and learn.

Associate II

Ok .. Now I tied to connect everythig after that I let you know if I need still help.

ST Employee

Hello @vdavi81,

Are you still having issues? If not, please close this post by selecting Accept as Solution

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.