Showing results for 
Search instead for 
Did you mean: 

Failed to start GDB server today

Senior II

I have a variety of projects I've been working on over the last year using a STM32Nucleo H7A3 board.. I use both the VisualGDB IDE and STM32CubeIDE.

I wanted to build a FatFs project from scratch using STM32CubeIDE yesterday and got it working surprisingly quickly. I powered down the Nucleo, pulled the uSD card and read it on my PC. The file was there with the right contents. I put the SD card back in the Nucleo and built the STM GPIO_InfiniteLedToggling example. It worked fine. I was putting some of the code from the LED example into my FatFs project and started getting a "Failed to start GDB server" error. All my STMCubeIDE project gave this error with slight variations. I tried some of the suggestions I found here and elsewhere on Google with no success. I figured I bricked the board somehow. Luckily I had another, new NucleoH7A3 board to use and everything worked again.

That was yesterday. Today the "Failed to start GDB server error" is back on the board I setup yesterday. The details are pasted below. I get a similar error when I try to run previously working projects in VGDB. I would really appreciate some help figuring out what I might be doing that is bricking my board and if there is some ST-Link utility (or other utility) that I can use to unbrick the board.



Senior II

FYI - I seem to have found a solution. I downloaded the STM32Cube Programmer utility from the ST website. I was able to use it to connect to my bricked Nucleo with the Mode drop down selection in the ST-Link Configuration window set to "Power Down". That was the only Mode that worked. Once I was connected I could use the utility to download one of my previously working .bin files and everything worked fine. I've tried a few other project directly from Visual GDB using the normal build and debug workflow, no STM32Cube Programmer, and those project have worked fine also. Hope this helps someone else.

Harvey White
Senior III

Normally what I use is the SWD mode. I've had problems when the debug settings under the IOC/debug are not set properly. I happen to use trace asyncnronous sw (not JTAG). If nothing is set, all bets are off.

I'm now seeing that same "Failed to start GDB server" message, after having successfully downloaded and run dozens of revisions of my project code today. A google search led me here, but I do not understand either of the answers posted here. I have that Programmer utility but the only "Mode" button I can find on it doesn't have a "Power Down" option. I'm trying to use the standard SWD download mode; I don't know what IOC/debug means. I've tried 3 different Nucleo G491 boards and two different USB cables. I've also tried running a known-working project and it now encounters the same issue. I'm dead in the water and looking for any guidance, thanks...