cancel
Showing results for 
Search instead for 
Did you mean: 

CubeIDE Clock Editor won't allow HSE selection with external clock

Andrew Neil
Evangelist

STM32CubeIDE Version: 1.13.0; Build: 17399_20230707_0829 (UTC).

 

It seems that the IDE greys-out the options to use HSE: 

AndrewNeil_0-1701107859575.pngAndrewNeil_2-1701108049197.png

Unless both PF0 is configured as RCC_OSC_IN and PF1 is configured as RCC_OSC_OUT:

AndrewNeil_3-1701108149468.pngAndrewNeil_4-1701108210571.png

 

Surely, it should be possible to use HSE when only PF0 is configured as RCC_OSC_IN - as shown in the Reference Manual:

AndrewNeil_5-1701108364238.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
TDK
Guru

You have to enable bypass mode under RCC. Just reserving the pin (i.e. the pin is yellowed out) isn't enough.

TDK_0-1701109500521.png

TDK_1-1701109533631.png

 

If you feel a post has answered your question, please click "Accept as Solution".

View solution in original post

4 REPLIES 4
TDK
Guru

You have to enable bypass mode under RCC. Just reserving the pin (i.e. the pin is yellowed out) isn't enough.

TDK_0-1701109500521.png

TDK_1-1701109533631.png

 

If you feel a post has answered your question, please click "Accept as Solution".

Ah, right - that does it.

Seems a bit clunky, though.

The 'resolve clock issues' didn't suggest this if I selected HSE and then switched back to just PF0 in clock mode.

And this is the IOC generated specifically for the F0-Disco - which, by default, has no crystal fitted and gets its clock from the on-board STLink.

It does manage to automatically set 'Crystal/Ceramic resonator' when you configure both PF0 and PF1 - so why can't it automatically set 'Bypass' when you only configure PF0 ?

🙄

Interestingly, on the F429, if you assign PF0 and PF1 to the oscillator it does not automatically set the HSE selection to crystal. But on the F051 it does. I doubt behavior like this is deliberately managed at the individual chip level. Just sort of works the way the machinery is set up.

If you feel a post has answered your question, please click "Accept as Solution".