Showing results for 
Search instead for 
Did you mean: 

STM32MP157C-DK2 flash didn't work.

Associate II

I've tried to flash STM32MP157C-DK2 SDCard like described in ST wiki with command STM32_Programmer_CLI -c port=usb1 -w flashlayout_st-image-weston/FlashLayout_sdcard_stm32mp157c-dk2-trusted.tsv.

and it didn't work! i got following error report. it seems it has trouble to reconnect the device. does anyone have an idea why it didn't work? or does anybody get similar problem? how do i get it working? Thanks a lot!


                       STM32CubeProgrammer v2.1.0                 


USB speed  : Full Speed (12MBit/s)

Manuf. ID  : STMicroelectronics

Product ID : DFU in HS Mode @Device ID /0x500, @Revision ID /0x0000

SN         : 0036004A3338510939303435

FW version : 0x0110

Device ID  : 0x0500

Device name : STM32MPxxx

Device type : MPU

Device CPU : Cortex-A7

Start Embedded Flashing service

Memory Programming ...

Opening and parsing file: tf-a-stm32mp157c-dk2-trusted.stm32

 File         : tf-a-stm32mp157c-dk2-trusted.stm32

 Size         : 245360 Bytes

 Partition ID : 0x01

Download in Progress:

[==================================================] 100%

File download complete

Time elapsed during download operation: 00:00:04.627

RUNNING Program ...

 PartID:     :0x01

Start operation done successfully at partition 0x01

Flashlayout Programming ...

[==================================================] 100%

Running Flashlayout Partition ...

Flashlayout partition started successfully

Memory Programming ...

Opening and parsing file: u-boot-stm32mp157c-dk2-trusted.stm32

 File         : u-boot-stm32mp157c-dk2-trusted.stm32

 Size         : 748660 Bytes

 Partition ID : 0x03

Download in Progress:

[==================================================] 100%

File download complete

Time elapsed during download operation: 00:00:13.495

RUNNING Program ...

 PartID:     :0x03

reconnecting the device ...

Error: unable to reconnect the target device: time out expired

Error: Start operation failed at partition 0x03

Error: TSV flashing service failed

Associate II

I changed the USB setting from "Full Speed" to "High Speed". It didn't help. It has the same problem.

Associate II

but in Windows 10 with GUI CubeProgrammer it worked. in VM doesn't.

Good to see it is working on W10.

Please have a look to

It is likely related to your VM behavior/settings around USB connection (e.g. in VMWare, you could check in 'removable device', if the 'STMicroelectronics USB download..." is connected to the VM and not to W10 host) .

In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.

I have exactly the same problem.

But it is solved when I add "-tm 20000".

Associate II

I had similar issue as reported originally:

RUNNING Program ...
 PartID:     :0x03
 reconnecting the device ...

For me the issue was solved by making sure that the VirtualBox guest has a USB-filter to re-claim the USB connection used. If this is not setup and the boot loader for some reason need to reconnect the device CubeProg in the VM guest will time out since it does not re-detect the USB-port of the MP1 device.

Did play with "-tm" option at all.

Joerg Wagner
Senior III

It's so annoying!

Equipment: Power supply 6A, native Ubuntu 22.04, USB Highspeed 480MBit/s

USB port disappears everytime and do you know what?

The board also, because I put it in the trash.

Tried many times to build a different linux image.

The only thing the board was good at: blinking a red LED, nice!