Showing results for 
Search instead for 
Did you mean: 

STM32WL55 CM0Plus is no longer able to work


Dear team!,

I have a problem with STM32WL55JC1 board.
I loaded the "LoRa End Node Dual Core "project and it works very well.
Then I made a project from scratch, with Dual core checkbox checked.
Before initialising any module, I built both projects and downloaded the exported elf files.
Then I tried an example to test the IPCC but I found that the CM0 is no longer able to start from its default address.
I've made a full chip erase using STProgrammer CUBE and loaded the "LoRa End Node Dual Core "project binaries to the board. But CM0Plus is not working. 
I've entered a debug session. I found that CM4 is working normally but CM0Plus after releasing it by CM4, it goes to 0x FF FF FF FE. I double checked the linker file for CM0Plus and it looks the same as the default example. 
I brought a brand new kit, loaded the "LoRa End Node Dual Core "project and it works fine. I checked the Flash Option Bytes from the working kit and compared with the died one and they were the same.
I have not changed any of boot pins on the kits. Just loading an empty project on both cores accordingly.
Please help me fixing this issue.
Thank you

Here's a screenshot 

ST Employee

Hello @MShafiee 

Sorry for my late replay. 

can you send the project you have used and give me the steps that you've been following to reproduce the issue.

Best Regards.



To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.