cancel
Showing results for 
Search instead for 
Did you mean: 

Bluetooth application on Nucleo WB55RG in Micropython

ropouillard
Associate

I'm trying to use Bluetooth on the Nucleo WB55RG board to make them communicate with each other. I find on internet a solution using micropython and Bluetooth import (this link of Solution: stm32python.gitlab.io/). However, when I activate the module, an ETIMEDOUT appears, so I try to increase the NIMBLE_STARTUP_TIMEOUT (up to 20s) but nothing changes. Not finding a solution to my problem I turn to you to try to find a solution.

I tried to update the firmware. Result: Memory erased but firmware crashed in the download. I still managed to put the compiled firmware back as shown on the previous git. By a happy miracle, the error changed to

tl_ble_wait_resp: timeout. 

Does anyone know why the bluetooth doesn't work?

Thanking you in advance.

2 REPLIES 2
Sarra.S
ST Employee

Hello @ropouillard​ and welcome to ST Community

Thank you for posting!

This GitLab is still under development, and there are ongoing updates on several applications.

However, you can use the firmware 1.19.1 (from downloads) and test this example (it is now available only in French, hope it's not a problem for you!)

but make sure to erase the memory with STM32CubeProgrammer first

Hope that helps!

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

ropouillard
Associate

Hello @Sarra.S​ 

Thank you for answers.

To my first test I followed your example (the french is not a problem). And my first error was

OSError: [Errno 110] ETIMEDOUT 

But for that I had stupidly followed the instructions (so by getting the code on git and not the 1.19 stable present on the site).

However by using 1.19.1 firmware this error appeared:

    tl_ble_wait_resp: timeout. 

(like explain in my question).

Thank you!