Showing results for 
Search instead for 
Did you mean: 

No such file or directory ERRORS

Associate II

I created an empty project with TouchGFX. immediately after, when I activate and compile Ethernet and LIWIP modules via the CUBE IDE, I get the following error: Description
fatal error: lwip.h: No such file or directory main.c/stm32h745i_disco_CM7/Application/User/Core line 23 C/C++ Problem.


When I create a project with Freertos without TouchGFX and activate and compile Ethernet and LIWIP modules in the same way, it adds all the paths to the project.

Ekran Görüntüsü (20).png

 TouchGFX version: 4.21.3

   CUBEIDE versiyon:  1.13.2

I uninstalled and reinstalled the CUBE I DEVE Touch FX compilers, made all the updates. but I'm having problems when I create the project with TouchGFX before.

ST Employee

Hello @fog.1 


Thank you for bringing this issue to our attention. I have escalated the matter to the relevant team for prompt resolution.


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Associate II

i tried to manually add non-existent paths related to the problem I mentioned, but I got meaningless compilation results that continued with different errors.