cancel
Showing results for 
Search instead for 
Did you mean: 

STM32L433RC SBSFU "Fw header authentication error"

HDevi.1
Associate II

Hello,

I am trying to run the Secure boot feature on STM32L433RC using the SBSFU library example project (single image slot). The example project I am modifying is STM32L432KC board.

Below are the modification/steps I made to example project to run on STM32L433RC:

  1. change the UART GPIO pins.
  2. change the LED GPIO pins.
  3. Disabled all the protections for now.
  4. Compiled SECore, SBSFU and User app.
  5. Downloaded the SBSFU to STM32L433RC.
  6. Opened Tera Term, Hit reset button.
  7. When asked to send the file using YMODEM protocol, I selected the SBSFU_UserApp.bin and the below error in the image is getting triggered.

Can anyone help me to successfully load the User app onto the board? Please let me know if I need to modify anything more or change the above modifcations.

Thanks!

0693W00000FBO1KQAX.png

2 REPLIES 2
Imen.D
ST Employee

Hello @HDevi.1​,

Let me first welcome you to the Community 🙂

Firmware header authentication error, means that during a local download procedure, the header could not be authenticated successfully.

This error is reached only if the header stored in RAM is altered (otherwise the download is bypassed without triggering a critical failure).

I advise you to refer to this UM2262 User manual "Getting started with the X-CUBE-SBSFU STM32Cube Expansion Package", that lists the main error messages together with their explanation. 

Hope that I've answered your question. If this the case, please close this post by clicking the "Select as Best" button. This will help other members of the community find this response more quickly 🙂.

Imen

When your question is answered, please close this topic by clicking "Accept as Solution".
Thanks
Imen
HDevi.1
Associate II

Hi Imen,

Thanks for the reference. Moreover, I would like to confirm that is there any step I am missing while modifying the example project

(STM32L432KC) to flash it on other board (STM32L433RC)? Above is the error I am getting after I followed the steps from integration guide AN5056.