cancel
Showing results for 
Search instead for 
Did you mean: 

The interface firmware FAILED to reset/halt the target MCU

cesarzerpa
Associate II

 

Hello,

I just bought an stm32 Nucleo-H743ZI2 and I can't upload a program with CubeIDE because it doesn't detect the stlink. Searching for solutions on Google, it seems it could be a firmware issue, and with STlink utility I get the same error, 'cannot establish a connection with the target', even after firmware update. 

Also, when I connect the board to the computer, a popup window appears with a text file containing an error message 'The interface firmware FAILED to reset/halt the target MCU'. What can I do in this case?

4 REPLIES 4
STTwo-32
ST Employee

Hello @cesarzerpa and welcome to the ST Community 😊.

I suggest you to try using another cable (data cable and not a charging one). Try using another USB port on your PC (or even another PC if possible) and don't forget to ensure that the jumpers are fitted as indicated on the UM2407 . Finally, ensure that driver are well installed (more details on the user manual).

Best Regards.

STTwo-32 

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

I have two USB cables, and I've tried them on my secondary PC and I still have the same problem. I'll try reinstalling the drivers and, in a worst-case scenario, the OS.

TDK
Guru

Use STM32CubeProgrammer, plug in the boad, does ST-link serial number show up on the right hand side? If not, does anything show up in Device Manager when you plug in the board? If not, probably you are not using a power-only cable.

ST-Link Utility doesn't work with that chip. Don't use it.

If you feel a post has answered your question, please click "Accept as Solution".

Yes, the ST Link serial number shows up. In the device manager, the STM32 also appears connected, along with the serial port it's connected to. I don't understand how it's detected by Windows while I can't access it with CubeIDE.