Showing results for 
Search instead for 
Did you mean: 

STM32L433 excessive power consumption in standby. Also, not always starting.


Hi, I have two problems.


I extensively searched the forum for infos. I found them, tried them, still failed (disable debug, deinit peripherals, set gpio to analog mode, gate the clocks).

I cannot get the MCU to consume less than 100uA.

I'm using a NUCLEO-L433RC-P board with a STM32L433RCT (not P, so without SMPS) mounted on it, removed JP6 for IDD measurements, SB76 removed just to be sure.

All the code does is init the HAL, wait five seconds then call HAL_EnterSTANDBYMode()

Am I missing something?


Sometimes MCU refuses to start. It absorbs 30mA and even with many hard reset (NRST or removing and applying VDD) it's not guaranteed to start. It's always the STM32L433RCT mounted on NUCLEO-L433RC-P.

Can't figure out why.

Thank you


ST Employee

Hello @Community member​ 

1) how much do you consume ? Is JP8 open (in other word un-power U11)? Doing nothing special with PB9 and PB11 (VDD12 pins on LQFP64 package wo SMPS) ? PB9 & PB11 are shortcuts on NUCLEO-L433RC-P board ! (be careful in bootloader mode where PB11=I2C2_SDA pin open drain and PB9=CAN1_TX pin push pull.

2) 30mA is quite high ! Boot 0 remains to GND with JP8 open ?



To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.


1) I consume around 1,5mA in RUN (1MHz) and 100uA in standby mode. JP8 is open and I do nothing with all the pins, it's a brand new empty project with 1MHz clock that goes to Standby mode after five seconds.

2) That's high indeed. Boot 0 seems to be 0V.

I wrote another code that toggles a pin and I saw that, when consuming 30mA, the program is not running so it must be for the shorted pins that you say. But why should the MCU start in boot mode when boot0 is 0 and the code is present?


Hi! We built a custom board and the low power modes work as intended.

Thank you for your time!