Showing results for 
Search instead for 
Did you mean: 

STM32G071CB unable to connect via SWD

Associate III

Hi, I've been working with this device for a while.

Today I started to try to write the option bytes in order to turn PF2 into a GPIO, which I did by writing an assembly file, compiling, and flashing via debug in Keil. I use a Segger J-Link as USB SWD interface

At one point Keil informs that it can't perform mass erase (which have been doing for quite a while). I connect with Segger Flash, which informs there is a protection in place and asked to perform mass erase, which resulted in an error I can't recall.

After that, the device is not detected by Keil, it doesn't show up as a connected device as before and Segger Flash can't connect to it.

Anything I can try ?

What could have caused this ? I wonder if Segger could have tried a "manual mass erase" and set BOOT_LOCK. As I said, have been mass erasing with Keil for a long time while working on this project.


ST Employee

Hi @scaprile​ ,

Is it possible for you to check with STM32CubeProgrammer?


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Since that tool does not support the Segger J-Link, and I don't own an ST-Link, I can only try connecting via the bootloader on the UART, what I already tried with stm32loader (, to same result: no connection.