Showing results for 
Search instead for 
Did you mean: 

STM32F469 discovery usb mass storage



sd card write on f469 discovery is working. and now referring to msc_standalone example (which works alone), usbd_storage_if.c file is matched and usb mass storage selected from MX tool.

But i cant see the drive coming. can i know steps have msc_standalone for MX generated code.


ST Employee

Hi @GauravK 

Could you share your project from github link or attach it to discussion? Did you succeed to enumerate it as mass storage device using this project?

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

project is working. can see drive having sd card data.

My tried project is attached. would be helpful to know the mistake.


Hello, I got USB FS for MSC on board working for F439 Nucleo. Now try is for USB3300 HS with Waveshare board.

I configured through MX and updated usbd_storage_if similar to FS changes. But I dont see USB getting detected in Windows.

Is this driver issue or code issue? (Tried installing mentioned driver for USB3300).

VCP driver looks to be not for Windows 10. 

CDC_Control(), I could find as suggested in net..since I want USB MSC