Showing results for 
Search instead for 
Did you mean: 

stlink v3 mini cannot program c031g4u6, Target no device found

Associate III

i am sorry for creating a lot of post recently but i just can not program my microcontrollers. 

when ever i try to program it i get this:

STMicroelectronics ST-LINK GDB server. Version 7.5.0

Copyright (c) 2023, STMicroelectronics. All rights reserved.


Starting server with the following options:

Persistent Mode : Disabled

Logging Level : 1

Listen Port Number : 61234

Status Refresh Delay : 15s

Verbose Mode : Disabled

SWD Debug : Enabled

InitWhile : Enabled


Target no device found


Error in initializing ST-LINK device.

Reason: No device found on target.


i have a stlink v3 mini and 3 stm32c031g4u6 microcontrollers soldered to proper breakout boards.

i have SWD interface soldered from the edge connector because i had no luck with cn4. 

SWDIO, SWCLK and RESET are connected. i also have an led soldered to power pins to be sure its powered.

i am sure of the soldering job.

on my first post someone recommeded i solder capasitors so i did that still no result.

i am using linux mint's latest and the code i am trying to upload is just empty machine generated code


here are the pics:

WhatsApp Image 2024-01-11 at 22.24.12.jpeg

WhatsApp Image 2024-01-11 at 21.59.11 (3).jpeg

WhatsApp Image 2024-01-11 at 21.59.11 (2).jpeg

WhatsApp Image 2024-01-11 at 21.59.11 (1).jpeg


WhatsApp Image 2024-01-11 at 21.59.11.jpeg



i made a breakout for cn4:

WhatsApp Image 2024-01-11 at 21.59.10.jpeg

  sorry for the bad solder job 

thanks for help


Accepted Solutions
Associate III

i have managed to narrow the issue to my stlink v3 minie. i went and bought a new stlink v2 mini and it works with cubeprogrammer with the current correct wiring. it appears that i have either fried the v3 mini or dont know how to use it. either way cubeprogrammer and V2 clone works for now

View solution in original post


Perhaps a wiring diagram?

The error means your part is NOT VIABLE.

Generally that means an issue with power, make sure the VDD, VDDA, VSS, VSSA pins are suitably connected. Or things are just not connected to the right things.

The VCC on the ST-LINK may also need connecting if it requires VTARGET for any buffers. Does STM32 Cube Programmer report the voltage it sees?

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

i know. 3.3V is coming from ams1117.

here is the wiring diagram. i drew it quickly 

WhatsApp Image 2024-01-11 at 22.45.39.jpeg

if you wait a bit i can draw it in kicad but i have to install it


Part is oriented wrong based on the footprint. Pin 1 marking on the chip doesn't match pin 1 marking on the board.



If you feel a post has answered your question, please click "Accept as Solution".



that is pin one not the one next to it

hold on

so pin one starts from the dot not the writing. give me a minute

WhatsApp Image 2024-01-11 at 23.10.55.jpeg

 okay i updated the wiring but still nothing. i checked with my multimeters buzzer and everything should be good. no sign of life 
green is SWDIO and its connected to TMS on cn2

white is SWCLK and its connected to CLK

any ideas?

i know i am being annoying but please help. i fixed the wiring but there is still nothing. reset pin is high, SWDIO and SWCLK is low 


for a moment i got an error for something about usb connection but now its back to same error

thanks for all of your help