Showing results for 
Search instead for 
Did you mean: 

ST-LINK/V2 USB Connection Error

Associate II

I connected STM32F401CCU6 board and ST-LINK/V2 with a SW called STM32 ST-LINK Utility. I'm sure it worked yesterday, but I don't know why it doesn't work now. The screen keeps saying "ST-LINK USB Connection Error" and plug in the USB and refresh, it will be connected for a while, and if I refresh, it won't be connected, so I think I'm going to lose my mind right now. I don't know what the problem is, what should I do?

Lead II

Hello @Park 

Can you test your ST-LINK on another MCU to make sure that it works fine. If so, use another ST-LINK and with your MCU. Also, try to look if it is an ST official product or an imitation. For imitation products, it can be a few unexpected problems. Finally, don't forget to check your USB cable and the USB port of your PC.

Best regards.


Principal III

symtom: sometimes working - sometimes not - right?

this is almost usb-cable or connection problem .  so try different cables, at different usb outlets.

and use stm32CubeProgrammer , not link utility (this is deprecated ).

and dont use old, worn out cables/plugs.

If you feel a post has answered your question, please click "Accept as Solution".

It's a imitation. I replaced it with a genuine one, but STM32 won't read.. What should I do?

what should i (we) tell you?

i know almost nothing, just that you tried under unknown conditions, to connect to F401 with a deprecated software.

so: what is your PC/system , st-link , board with F401 ? condition: new? did it already work/connect?

use stm32CubeProgrammer now? tried different cables, at different usb outlets ?

If you feel a post has answered your question, please click "Accept as Solution".


I will attach the image of my cell phone using two different computers. Please understand.

I don't know if you can see it well in the picture, but I'm connecting with ST-LINK/V2 using STM32F401CCU6 board by referring to other YouTuber videos and using "ST-LINK Utility" SW. Yesterday, when I connected with a fake product, it went well, and now I replaced it with a genuine product and ran it, but I can't read the STM32 (Target) although the USB Connection Error doesn't come out. Do you understand me?

Try with CubeProg. This utility is deprecated. If it doesnt work, change this horible wires and recheck if they are on the right pins. And, are you sure, it si the true STM32 product?.





I think they say they can't find STM32 because the target voltage is 1.24V, should we replace the MCU?


I think you should wire the 3v3 of the MCU to the 3v3 of the ST-LINK. If the problem persist,Try another MCU.

Best regards.


Do you have connected pin for MCU voltage sense? I see only 3 wires on the photograph. If MCU works according to last flashed program, is probably OK.