cancel
Showing results for 
Search instead for 
Did you mean: 

Error trying to flash program from eclipse using stlink to nucleu 144 F767ZI

JBlac
Associate III

I'm having problems flashing my program (.hex) file to my nucleo F767ZI board. If I try to connect using ST-LINK gui, I have problems connecting. Program comes back with "No elf loader found for this operation. I've looked at External Loader-> add External Loader but there is no loader listed for the F767 board. Don't know how to proceed from here. Need help.

3 REPLIES 3

You are building code incorrectly. Check the linker script and MAP file to identify the memory/source of the issue. ​

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..
JBlac
Associate III

The two parameters in the .ld file that I was led to believe need to be modified are the RAM size and address and the FLASH size and address. My board has 2Mbytes of FLASH and according to memory map address is 0X8000000, RAM is 512kB and address is 0X2000000; I set these two lines in the mem.ld file. Am I missing something else; or, are these values incorrect? I pulled the address values from the datasheet/reference for the STM32F7x7 series manual.

RAM at 0x20000000 not 0x2000000

The Error is indicative that the linker is creating a .HEX file that touches memory regions outside the scope of the part's internal memory.

LOOK at the .MAP file to identify what's driving the ERROR.

I'd have to see the .LD, .HEX and .MAP to be able to deduce the issue remotely.

/* Specify the memory areas */
MEMORY
{
FLASH (rx)      : ORIGIN = 0x08000000, LENGTH = 2048K
RAM (xrw)      : ORIGIN = 0x20000000, LENGTH = 320K
}

STM32Cube_FW_F7_V1.12.0\Projects\STM32F767ZI-Nucleo\Templates\SW4STM32\STM32F767ZI_Nucleo_AXIM_FLASH\STM32F767ZITx_FLASH.ld

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..