Showing results for 
Search instead for 
Did you mean: 

Why does the motor profiler flash a red dot next to under voltage?

Associate III

I am running the 5.4.8 motor profiler on windows 10, the board is attached to the laptop with a suitable USB cable. It's powered by a bench power supply, and the leads are connected to an emax 1106 6000 kv BLDC motor.

I have set it to 6 pole pairs and tried a variety of options 5 /12v 5ams/20amps, 6000/72000 rpm - it behaves the same way.

On plugging in the USB and powering up the board the red led, and 2 green leds are lit.

I can connect the profiler, and then tell it to profile. It runs the electrical model for several minutes and the little red dot next to Under Voltage flashes.

Any idea what's going on?

The power supply is providing the volts - could it not be supplying enough current?

Principal III

>The power supply is providing the volts - could it not be supplying enough current?

Maybe. Can you set a current limit on that bench power supply? What do the power supply specs say?

Try with less amps setting in the profiler.



Ignoring this issue for a sec ...

I ran code generation, and compiled it in STM32CubeIde, then tried to run it. The code uploads to the mcu and I can run it in debug mode. I then ran the code, opened the motor control workbench and successfully connected on COM3/115200. I press "Start Motor" and get "Command Start Motor done. The STLink board led is green. However the motor shows no signs of life (it is a tested/working motor). If I now "Stop Motor" - it fails Send Data (0x14).

Any idea? Could this be a symptom of the same issue the motor profiler is having?

I am unable to determine the current this power supply can deliver - I'll need to drum up another one that'll give me a read out before I try again - ah seems so close ...

Associate III

BTW - is there any way to debug the code while running the motor control workbench? It seems like it's either the mcwb or the debugger - they can't share the connection.

Associate III

One more thing - the motor profiler manual for 5.4.6 (I m using 5.4.8) says "The STM32 MC motor profiler has the following limitation: it cannot profile motors with Rs < 1 Ω or Ls < 1 mH."

The emax 1106 measures at: 0.18 Ω and  0.004mH - could this be the issue?

What version of the motor control workbench should I be using? The download instructions are confusing.

Associate III

More info ...

I gave up on the profiler based on the warning in the manual (see above). I opened the 5.4.8 motor control wb and edited in the values for the motor 6, 72000, 8, 12, 0.18, 0.004, 6 and turned off the sensors and saved it. My power supply is providing 13v.

I generated code, opened it in STM32CubeIde, built it and ran it in the mcu board.

I open the monitor in the wb. Connect the wb to the board, and start motor. The first time I did this the motor moved!, subsequently it has not. I can't seems to repeat my test - argh.

If I try changing the rpms in the UI - the log says: Ramp final speed commit failed, SendData (0x14)

Any ideas?