Showing results for 
Search instead for 
Did you mean: 

X-CUBE-AI 8.1 is out!

ST Employee

We are pleased to announce that the latest version of STM32Cube.AI is now available.
You can download it here.

What is new in X-CUBE-AI 8.1.0?

  • TensorFlow 2.12 and 2.12
  • ONNX Runtime 1.15.0
  • Host PC system: adding support for MacOS ARM system
  • Include new version of the TensorFlow Lite for Microcontrollers library (SHA-1: 6a1803)


  • Improved inference time for quantized convolutional kernels
  • UI: add specific checkbox allowing to set the “–no-onnx-io-transpose” option
  • CLI: enhance global model format detection, improve the report of the number of operation per layer
  • Core - Code generator
    • optimization of the quantized kernel implementations: CONV2D (151774), ADD (153931)
    • add support for new layers:
      • Einsum (bz121864), BitShift / ONNX Operators
      • Support to the gather with second input variable (TFLITE & ONNX Operators)
      • Support to LSTM with constant inputs not put in initializers (141640)

Major bug fixes

  • (129411) TFLITE - support for transpose of batch dimension
  • (152744) ONNX - enhance import of concat operator managing arbitrary inputs order
  • (148917) ONNX - enhance import of resize operator considering the constant inputs
  • (135654) TFLITE - enhance Dilated convolution 1D/2D (SpaceToBatchNd/BatchToSpaceNd)
  • (141553) ONNX - support transpose lop between dequantize and convolution ops
  • (144706) run-time lib - extend n_macc resolution to 64b
  • (149752, 150344) code gen - memory allocator, enhance multiple heap support

Feel free to learn more about our STM32Cube.AI by looking into our documentation!

Attention: X-CUBE-AI works as an extension (pack) of STM32CubeMX. It requires STM32CubeMX 5.0.1 or newer versions.

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.


X-CUBE-AI 8.1.0 is not found when checking for updates with the CubeMX Embedded Software Packages Manager. Manually downloading and installing with the "From Local" option worked fine, but the CubeMX update site needs to be updated.