Showing results for 
Search instead for 
Did you mean: 

Error in downloading


I am trying to use the STM AI by following the instructions in this document.

I get the above mentioned error while trying to download it from the CubeMX.

I tried downloading it from this website and it simple does not start downloading.

I tried downloading it from its Github repository and it gives a network error.

Could you please let me know how to resolve this issue?

Thank you.

ST Employee

Unfortunately if you are sure your proxy configuration is correct the only thing you can do is retry the download from time to time from STM32CubeMX




This problem still exist, i changed proxy configuration and checked credentials more than one time..

These are the phases i see:

1) the download proceed correctly until the end (1239MBytes)

2) Unzip File:

3) Connection to HTTP Server ...

4) ERROR downloading the following files: (Timeout during download)

Since the first zip has been downloaded correctly i think is not proxy or my fault.

ST has historically had issues with files >1GB, for reasons that are particularly clear, and they provide three different sources to pull files from.

I've also found proxies can also be unreliable, especially if not maintained.

Perhaps you can download the files manually, from the Cube F7 pages, and then "Install from Local"

The sub-versions may be patches applied to the major versions. Make sure to install v1.16.0 first, and then do the incremental.

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..

@Community member​ thanks for the really fast answer!

I'm trying to follow your guideline, the base version 11.6.0 is done, then downloading the patch from Cube F7 page, but do not work properly anyway installing from local with the downloaded patch..

Why the version of the Firmware used is directly associated to the version of the CubeMX? There's the possibility to migrate to a different version of the project and not simply "the last one associated to the current version of your CubeMX"?

I'm now trying to downgrade to CubeMX 6.2.0 and use the second last version of the F7 FW, since is the CubeMX 6.2.1 that is associated to the 16.1 FW release

@fauvarque.daniel​  @Imen DAHMEN​ 

Something amiss here, current CubeMX just downloaded/installed, checked install of last two F7 packages


Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..

Thanks @Community member​ for pointing out this issue, I will share this with CubeMX team.

Hello CubeMx team (@Nawres GHARBI​ , @Houda GHABRI​ , @Khouloud OTHMAN​ , @Khouloud ZEMMELI​ )

Can you please have a look on this issue?


When your question is answered, please close this topic by clicking "Accept as Solution".
Khouloud ZEMMELI
Lead III

Hello @AS.4​ , @Community member​ 

Thank you for your feedbacks,

It will be internally checked, I'll give you an update as soon as possible.


Forced it to reapply, and it looked to process the 1.16.0 ZIP again, and then apply the 1.16.1

I have initially tried from a fresh install, and checked both 1.16.x packages for install, and clicked Install Now

Second pass the 1.16.0 was flagged as installed, and I checked 1.16.1 again, and then installed.

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..

Hi again,

I was able to reproduce problem, it's not a systematic issue.. now, it's under analysis and it will be fixed.

Thanks for raising the point.