Showing results for 
Search instead for 
Did you mean: 

Two boards STM32H757I-EVAL seem dead after USART1 (CN2) to RS232 connection

Associate II



I got two boards dead within one day. I used the first board for a while and it worked until I started to communicate via USART/RS232. After I faced with such a problem, I replaced the board with a second one and immediately got same result.


The eval board was powered via STLINK-V3E USB (CN23). JP10 in corresponding position, no other jumpers are reconfigured. No connection to RS232 at the beginning. LCD display showed a nice picture, IDE successfully uploaded and debugged both M4 and M7 etc.

Power off and on at least with the first board did not change the situation as well.

Then I connected it to a PC com port (USART1 via CN2). To do that I used a USB to COM convertor from StarTech.

At the beginning of debugging I got in a PC terminal:

"STM32H747I-EVAL: STFirmware (Fractal) V1.0.0 (Build Feb 8 2019 at 19:22:02)
CPU running at 237MHz, Peripherals at 118MHz/118MHz"

and then my own prints and readings.

Then the story with two boards a bit differs. For example, with the second board I very quickly (in couple of minutes) faced with USART malfunction. It became unable to transmit. Or transmitted just couple of chars I wanted and got stuck.

Anyway, once I turned the board off and then turned on again - no LCD picture and no ability to upload and debug the executables. With the second board and with the first. Both today.

"Target no device found


Error in initializing ST-LINK device.

Reason: No device found on target."

"Error in final launch sequence:


Failed to start GDB server

Failed to start GDB server

Error in initializing ST-LINK device.

Reason: (4) No device found on target."


That happened with two boards in turn.

Besides, I tried to use STM32CubeProgrammer utility. It says that on-board ST-Link programmer is not able to detect the target MCU.


Your comments?

Pavel A.
Evangelist III

If you use the LCD, please connect the external power supply. The USB power from the ST-LINK USB is not enough.

Check the jumpers. Someone could tamper with the board before you.


Associate III

If your USB to COM convertor from StarTech is RS-232, you cannot connect that directly to USART pins...



something like this :


ed: this is wrong. The CN2 is real RS232 connector, so i was wrong.

IF yes - you killed the cpu's.

Because this is real RS232 with RS232 level output (+/- 8 V or so) , but cpu is 3v3 system and needs a RS232 signal - but at 3v3 voltage level !

So replace the damaged cpu's , or buy new board. Then use for USB - Serial converter something like this :


USB -> serial (3.3 V level)


If you feel a post has answered your question, please click "Accept as Solution".
Pavel A.
Evangelist III

>IF yes - you killed the cpu's.

No. The H7 Eval boards have a normal DB9 RS232 connector.


@Pavel A.  , your right. I just was thinking, he connect to a cpu uart ...

but CN2 is :


But then : what he did wrong ?

If you feel a post has answered your question, please click "Accept as Solution".

CN2 is a DB9 RS232 port on EVAL board, top center-left


I don't see this electrically damaging the board unless something is very wrong with the PSU and grounding situation.

The claim here is the STM32H757 is damaged.

The STM32H7's can be come difficult to communicate with and debug if the LDO/SMPS configurations don't match the hardware.

There's a power-cycling, BOOT0=HIGH method to recover those.

As Pavel points out the board really needs to run from the DC supply, the one provided in the box..

More probably a power / regulator issue than one of RS232 per se..

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

Unfortunately no suggestion helps.


I dismounted the display. No effect.

I switched power supply to 5 VDC power jack (PCU to CN10) with corresponding JP10 reconfiguration. No effect.


All results are identical on both boards.


Besides. I measured currency and voltage in test all test points I found. For both boards and both powering I also got identical results, as follows:

Currency on JP9 (with removed shunt) - 1 .. 2 mA (0.001 .. 0.002 A).

5 V (TP5) - perfect

3.3 V (TP7) - perfect

2.9 V (TP8) - perfect

1.8 V (TP12) - perfect

A also measured my USB to COM and got +/-9 V.


In both cases USB (CN23) is good. IDE succeeded to upload an upgrade for some peripheral before to unsuccessfully attempt to upload my executables.


And let me emphasize one time more that both boards actually worked well (but USART) until I switched them off and then on. At this, USART already got inapplicable. 


Failed at power cycling might be the LDO/SMPS issue. Set BOOT0 HIGH and power cycle the board a couple of times. Then attempt to connect with STM32 Cube Programmer, and mass erase the internal Flash.

Power cycling is treated differently than simple Reset.


Suggest you open an online support request ticket if you believe the board is electrically damaged.


Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..
Associate II

Tesla DeLorean,

Thanks a lot! Yes, switching of a SW1 to the position 1 (BOOT0) followed by the flash erasure indeed solves the problem on both boards, but not completely.

I indeed became able to upload new executables and debug them.

But there are still at least the following bad things:

1) I fail at the beginning of the main() of M7-core when the following code is executed:

timeout = 0xFFFF;

while((__HAL_RCC_GET_FLAG(RCC_FLAG_D2CKRDY) != RESET) && (timeout-- > 0));

if ( timeout < 0 )




So, I get into the Error_Handler()

It happens every time. Debugging of the M4 (another main()) does not show a wrong behavior. All initializations seem to be executed perfect.

2) Even without COM port I after a while again became unable to work with the same symptoms as earlier. I.e. I have to erase flash again.