Showing results for 
Search instead for 
Did you mean: 

STSW-Link-004 flash tool crashes on windows 10

Posted on September 06, 2015 at 09:16

I have a new 32STM429I-DISCO board (with LCD). My first step is to download the demo program from the board to a file as I did not find that binary anywhere, so I could flash that back later. I tried to use the ST-LINK tool but it crashes (see details below)

A Linux tool under Ubuntu 15.04 64bit can detect the board but I am not familiar enough with that tool yet how to download the program form the board.

Thanks a lot for any help to accomplish my goals.

Windows 10 problem details


STSW-Link 004, Windows 10 64 bit. Selecting target=>connect, utility crashes. The driver in device manager does not shows any problems.


The DLL exists in C:\windows\system32.  Selecting ''debug'' shows this in visual Studio



#windows-8 #stlink #32stm429i-disco-demo-st-link
Posted on September 08, 2015 at 12:22

Hi Happy,

If you want to have the demo of  STM32429I-DISCO, you do not need to dowload it. All demonstrations are available under STM32Cube_FW_F4_V1.8.0\Projects\STM32F429I-Discovery\Demonstrations.


Posted on September 09, 2015 at 06:42

The Cube package seems to have no binaries. I haven't get up to speed how to compile code and don't have plan to spend lot of $ yet on a development toolchain because I am just evaluating the STM32 right now. I thought, just to download the binary would be quicker but the tools crashed (tried another Win10 system and the same thing happened)

The alternative might be using Linux flash tool to extract the binary or to compile Cube.  I found this

. But even then , after compilation, still need to flash it, that would mean flashing under Linux, since still .. the STLINK on windows 10 crashes.

Would this work to extract it all and then write it back with a 'write' ?

st-flash read v2 myflash.bin 0x8000000

Andrew Neil
Evangelist III
Posted on January 07, 2016 at 14:53

Maybe a bit late to this, but which version are you using?

A colleague tried to use the STLink Utility v3.8.0 with a new Win-8 HP Laptop, and the utility would always crash on 'Connect to Target'.

v3.7.0 had no problems on a (nominally) identical Win-8 HP Laptop.

v3.8.0 could be made to work by setting Windows Compatibility settings for XP-SP3.

Maybe that helps someone ...