Showing results for 
Search instead for 
Did you mean: 

STM32G0B1RE failed to connect

Associate III


My nucleo stm32g0b1re board is failed connect after option byte Boot0 checked in Flash Security.


I've tried many ways to connect board/ease modified SBSFU  on the flash but no luck. could someone help me to recover board?


ST Employee

Hello @Tarun , 

If you are unable to connect to your Nucleo STM32G0B1RE board after enabling the Boot0 option byte in Flash Security, it is likely that the board is stuck in bootloader mode. To resolve this issue, you can try the following steps:

  1. Disconnect the board from your computer.
  2. Short the BOOT0 pin to GND using a jumper wire or a switch.
  3. Reconnect the board to your computer and try to connect to it.
  4. If you are able to connect to the board, you can clear the option byte by erasing the chip or using your programming software to clear the option byte.
  5. Once the option byte is cleared, you can remove the jumper wire or switch from the BOOT0 pin and try to connect to the board again.


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Hi Foued,

I shorted pin 7 and 8 in the image but still same error seen on the Cubeprogrammer.  Is am I missing anything?





Associate III

Sorry it didn't helps. I have to replace my dev kit.