Showing results for 
Search instead for 
Did you mean: 

ST-LINK V3 SET Firmware Upgrade Failure


0693W000007E6s0QAC.jpgHi, how can I do?

Ricky Gai
Associate III

I encountered the same problem, I received ST-LINK V3SET three days ago, and is a new unit but cannot do a firmware upgrade via STM32CubeProgrammer as picture shown below:


Did they work properly before?

Cheap/charging cables?

Try with better cables.

Try with the stand-alone utility, not spawning from STM32 Cube Programmer.

To troubleshoot or identify common causes it would be super helpful to provide as much system context as possible.


Make and Type of machine.

Version of Windows, Corporate or Personal.

Use of Hubs or Docking Stations.

Rear or Front USB ports.

USB2 or USB3 ports.

Types of other software, AV, Remote Diagnostic, Optimization Tools, Policies, etc, installed on the machine which might stop in functioning normally.

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..
  • The STLINK V3SET is a new unit, first day received, tested immediately, result as mentioned.
  • Already tested, both USB cables are working on Arduino and had been used to connect this STLINK V3SET.
  • Tested using STLINK UTILITY, unable detect as well and standalone STLINK Upgrade.
  • Already checked Dupont cables/wires, all OK.

  • STM32CubeProgrammer 2.5.0
  • ST-LINK Utility
  • STLinkUSBDriver.dll v5.1.2.0
  • ST-LINK_CLI.exe v3.6.0.0
  • Latest ( recent download ) en.stsw-link009 - USB driver for ST-LINK V2, V2-1, V3 and Nucleo boards
  • Microsoft Windows 10 x64 Version 20H2 (OS Build 19042.804), 16G RAM, nVidia 2070 GPU

I am returning this unit to Element14, to obtain a replacement later.


I had the same with STLinkUpgrade 3.3.7. I have been using this device for one year and tried to update it and was left with bricked device now.

Is there any way to recover it ? Or maybe the second stlink to reflash the first one ?

Associate II

I have the same problem in a linux machine. I used the en.stsw-link007_v3-10-3 utility to update the st-link firmware of a STM32H747I-DISC0 module and it worked ok. Next, with the same USB cable and software utility the upgrading process failed for a second STM32H747I-DISC0 module and this module is now bricked.


Two year old thread to which ST hasn't officially responded with advice, or solution.

Start a NEW thread.

Version numbering also looks inconsistent.

@Amel NASRI​ @STOne-32​ 

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..
Associate II

Hi, I might be a little late to the party, but I solved this kind of issue here:

Hope it helps!