Showing results for 
Search instead for 
Did you mean: 

STWLC38: GUI connect No response

Associate II


I have a custom board with a STWLC38JRM.

Everything was fine and I was able to flash it with STSW-WPSTUDIO v1.8.4 through the dev board STEVAL-WLC38RX and FT_SDA/FT_SCL/VBUS/AGND pins.

I try to make some test and I disabled internal overtemperature protection in config. After that, I'm not able to connect to the STWLC38JRM again. I tried the chip with "RX" and "Empty" in WPSTUDIO without any success. I already had a similar issue and the chip was in Empty state.

Is it possible to "factory reset" the chip without I2C link ?

Thank you.

ST Employee


We only use I2C to update fw, please make sure FT260 dongle is ok ,

about GUI connect issues, i suggest you use

a1_wlc38_downfw.bat to download fw automatic.

Also please check GUI log and post it if still fail.



In order to give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.