Showing results for 
Search instead for 
Did you mean: 

SPC58EC80 CanBus RTR Frame Request

Yali Mobilities
Associate III

I'm using SPC58 DISP Board for RTR request data frame from a battery pack. I have set the RTR value as 1, but didn't receive any reponse data frame from the battery. I have tested with CAN analyser, reponse data frame is coming(working fine). When I looked into the code, I didn't see any RTR register loading with the value. So, if anyone worked on RTR frame request. Kindly guide me.

Screenshot 2024-06-19 185331.png

Transmit data frame with RTR as 1.


Erwan YVIN
ST Employee

Hello ,

do you solve your issue ?

Are you well in CAN FD Format ?


          Best Regards




Actually I'm using CAN2.0 without FD.

I got RTR frame by adding some code which is included below. But the problem is If I tried change the data, its doesn't change in the CANbus message.

The code I included before the "Data Length" section in the "can_lld_writeTxBuffer" function.Screenshot 2024-07-18 172639.png

The code in the main function. Here I have increamented the data8[0] by 1 every loop. But it doesn't reflect in the CANbus message.Screenshot 2024-07-18 172055.png

Screenshot 2024-07-18 173640.png

The edited "can_lld.c" file is attached.

Best regards