Showing results for 
Search instead for 
Did you mean: 

LSM6DSO not replying on I2C

Associate III

Hi all,

I have a custom board with an LSM6DSO connected to an STM32F072 on I2C.

The IMU shares the I2C bus with other sensors that can communicate with the MCU without any issue, so the bus is working.

The LSM6DSO instead does not reply, there was an error in the schematic because there was a pullup resistance on INT1 that has been removed, so the sensor should correctly run in I2C mode. But it does not. SA0 is on GND, so it should reply to the address 0x6A, but it is not possible to read the WHO_AM_I register (see attached picture).0693W00000FDBjNQAX.pngI tried to change the configuration of the INT1 pin on the MCU, leaving it unconfigured, setting it as output pin in push-pull mode with and without pull-down, and I also tried to set it as open-drain, but without success.

Do you have any clue about the possible causes of this problem?

Following the schematic of the circuit, R125 and R240 have been removed, SCL and SDA have 1k pull-up to 3V3:


Thank you in advance,



Hi @Community member​ ,

ok, let me please know if it is working with the X-NUCLEO-IKS01A3. Will you wire your board to the DIL24 connector of the X-NUCLEO?


No, I'm going to use it with a Nucleo64. It's not possible to wire it to our own PCB