Showing results for 
Search instead for 
Did you mean: 

ASM330LHH gyroscope always sent 0 after few second

Associate II



I use a nucleo L432KC for a POC with an ASM330LHH. I use the internal FIFO of the ASM330 to store accelerator and gyroscope datas. I use an SPI to get datas periodically.

During developpment, we used the 3.3V of the nucleo to supply the ASM330. We didn't notice this issue

Now, we use a lipo battery and a traco DC-DC module to do my 3.3v. With it, I supply directly the STM32 on the nucleo and the ASM330. After a few second, the gyroscope always sent 0 dps on the 3 axes. The accelerators are OK. If we used a 3.3V laboratory power supply, we have the same problem. The only solution to use the gyroscope is to use the LDOs on the nucleo demoboard.

 Other information, during time that the gyroscope giving data, I "lost" regulary a data  from accelerator( 3 axes sent 0g).

Thanks for your help or your tips

Graph for Accelerator (0g problem):


Graphs for gyroscope : 






Associate II




Federica Bossi
ST Employee

Hi @dlb ,

Are you sure you are supplying the maximum current the sensor needs? About 2.5mA?

I also suggest you monitor the voltage when it crashes


In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.

Hi Frederica, 

The traco power module can supply 500mA and we only use 40mA during the writing in the SD card. We did some tests with a laboratory power supply directly to do the 3.3V, we have the same result. The only solution is to use LDO from Nucleo.

Other information : we use a second accelerometer for high G and we saw a difference of 100ms to see the same event (the ASM330 is late). 


thanks for your help ....