Showing results for 
Search instead for 
Did you mean: 

STM32CubeProgrammer Failed to Flash 128GB MicroSD Card on OSD32MP1-RED board

Associate II

STM32CubeProgrammer v2.10, running on Ubuntu to flash a 64GB MicroSD card on OSD32MP1-RED board is successfull, but failed to flash 128GB MicroSD card on the same board.

Same tsv file and image binaries are used. MicroSD Card is 128GB SanDisk Ultra MicroSD XC1.


STM32CubeProgrammer logs end as follows:

RUNNING Program ... 

 PartID:   :0x03 


Reconnecting the device ...


USB speed  : High Speed (480MBit/s)

Manuf. ID  : STMicroelectronics

Product ID : USB download gadget@Device ID /0x500, @Revision ID /0x2001, @Name /STM32MP157C?? Rev.Z,

SN     : 001800273239511637383434

DFU protocol: 1.1

Board    : --

Device ID  : 0x0500

Device name : STM32MP157C?? Rev.Z

Device type : MPU

Device CPU : Cortex-A7

Start operation done successfully at partition 0x03

Error: an error occured while uploading data from the virtual partition 0xF1

Received PhaseID == 0xFF, system is going to reboot


Attached debug logs shows failure is due to the dfu_read function receiving WRONG partition name "@fip/0x06" instead of "@virtual/0xf1".

This partition name is passed into the dfu_read function, as "DFU alt settings list" index, through the USB_REQ_SET_INTERFACE message.

It looks STM32CubeProgrammer is sending worng partition index in USB_REQ_SET_INTERFACE message to dfu driver.


Is there any limit on eMMC/SD card size STM32CubeProgrammer can flash.

ST Employee

Hi @farid​ ,

There's no limit/restriction on SDCard size.

You are using latest CubeProg .. What is the OSTL version provided by Octavo for their board ?

Can you share both SDCard reference and class ?



In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.
Associate II

Hi Olivier,

MicroSD Card is 128GB SanDisk Ultra MicroSD XC1

ref. 7516DVLHEONQ

Image is built on OSD32MP1 Debian SDK v3.0

Debian 11 (bullseye)

TF-A v2.4-stm32mp-r1

U-Boot 2020.10-stm32mp-r1

Linux Kernel v5.10-stm32mp-r1

Also we've a custom board built with 128GB eMMC Kingston PN=EMMC128G-TX29-8AC01

Getting the same error when trying to flash with CubeProgrammer.