cancel
Showing results for 
Search instead for 
Did you mean: 

stm32u5 cube programmer fail to download without full chip erase

junichi ohashi
Associate II

I want to write firmware to stm32u575 using cube programmer, but when I do download from the erase & programming section, it fails to write.

Of course, I have turned off the "skip flash erase before programming" checkbox.

However, if I run the program in automatic mode with the "full chip erase" checkbox checked, it writes successfully.

With the L4 and G4 that I have used in the past, I was able to write successfully in both cases, but with the U5, it fails.

When I use the U5, I use cube programmer.dll to perform full chip erase before downloading.

,Has this behavior changed since the writing of u5 microcontrollers in the specifications?

I have confirmed that the option byte is factory default.

 

2 REPLIES 2
FBL
ST Employee

Hello @junichi ohashi 

Could you please share the log? Are you flashing secure firmware? It is possible that the firmware needs to erase/reset the chip before programing the flash.

 

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

sorry.

this problem source is by my circuit design cause there was no problem encounted in stm32 nucleo u575zi-q.

I will look into the cause now.