Showing results for 
Search instead for 
Did you mean: 

How to open STM32CubeMX 6.3.0 on MacOS??


I downloaded and extraced STM32CubeMX for MacOS. Double clicking the file doesn't do anything


Hello @Community member​  ,

First let me welcome you to the STM32 community and apologize for the somewhat late reply.

In fact, the STM32CubeMX User Manual details the installation process on the different OS. To install STM32CubeMX, make sure you have administrator rights and in case you face a problem when double-clicking application file to launch the installation wizard on MacOS, try to fix it: - $sudo xattr -cr ~/

Otherwise, you can try installation from command line (run the command jre\bin\java -jar SetupSTM32CubeMX-<VERSION>.exe).

Hope this will help you.


Clark Sann

Hello @Khouloud OTHMAN​,

Thank you for your offer to help with this problem. Unfortunately, the solutions you provided to install CubeMX 6.3.0 on the latest version of MacOS do not work.

I first tried to follow the instructions in the readme which says:

  • Double-click application file to launch the installation wizard.
  • In case of error, try one of the following fixes: - $sudo xattr -cr ~/

That did not work.

Here are my notes of what I have attempted so far:

  • I tried double clicking the Setup file. MacOS complains it cannot be verified.
  • I tried right clicking and selecting Open. Nothing happened.
  • I then opened a terminal in the folder where Setup is located.
  • I then, after adjusting for the correct folder that the Setup file is in, I ran the sudo xattr command as specified in the readme. It runs and does not create an error. That command only clears all file attributes so it would not be expected to launch the Setup program. It might be best to modify the readme so inexperienced people understand what is the expected result of that command.
  • Moving on, I then tried to double click on the modified Setup app, MacOS again complained the file cannot be verified.
  • So then I tried right click / Open. Now MacOS complained the java program could not be run because it was not verified.
  • Lastly I tried your instructions after adjusting the command for the Mac. That did not work either because jre/bin/java cannot be found. The java app was found in Setup zip file/jre/Contents/Home/bin. However because that program cannot be verified, it is not allowed to run.

I don't know what else I can try.

Would it be possible for someone to test the installation of CubeMX 6.3.0 on the latest version of MacOS? That would be 11.5.2.

If I recall correctly, I have had difficulty installing CubeMX on MacOS for the last several versions of CubeMX. I do not recall having problems with CubeIDE, CubeMonitor, CubeMonitor-Power, or Cube Programmer. It it possible that the installation procedures used for those other apps could somehow be used for CubeMX?

Thank you for your help! I need MX6.3.0 to start a new Nucleo-WL55 project. So I guess I can't start on that until I can install this version of MX. Lucky for me my laptop still has the previous version of MX installed so I can continue working on my other projects.


Clark Sann

Could someone from ST please help with this problem? @Khouloud OTHMAN​ or someone?

Hello @Clark Sann​ ,

My apologize for the delay I take to answer, I've missed the notification.

It is a bit odd that you're still facing the same issue, what I can propose in this situation is to re-run $sudo xattr -cr command in the file containing both .app and jre file.

Otherwise, the MacOS firewall may consider STM32CubeMX as malicious application, thus you can try to Disable Gatekeeper on your macOS before installing the tool.

Hope this solves your issue.



This is an old question, but I ran into the same problem today and here is how I fixed it:

Once I reached the step quoted below, all I had to do was go to system settings -> Privacy & Security and scroll to the bottom. There you'll see a pop-up stating Java has been blocked. Press on "Allow anyway" and redo the step quoted below.


@Clark Sann wrote:
  • So then I tried right click / Open. Now MacOS complained the java program could not be run because it was not verified.


Hope this is helpful to someone since the problems haven't been solved yet.


Howdy folks, I got this working by downloading the app, double clicking it (then Mac tells you it is unverified and cannot be trusted (cmon STM just pay the $100), but then you open settings and go to Privacy and Security, scroll down and click "Allow Anyways". Then... it did nothing! I realized that I did not actually have java installed so open up a terminal and run "brew install java", or install it some other way. Then, you double click the app again! And again, it will probably tell you Java is unverified. So, go back to privacy and security and click allow again. Finally - double click the app and it should open up the installer.