Showing results for 
Search instead for 
Did you mean: 

Unable to use SWV Data Trace Timeline Graph

Associate II


I want to use SWV Data Trace Timeline Graph but when I try to open "Configure trace" option, nothing happens, not a single window is being opened etc. Is it some kind of bug, does it have a solution? Thanks in advance.

My IDE and other information are as follows:


Version: 1.0.2

Build: 3566_20190716-0927 (UTC)

OS: Ubuntu 16.04

Board: Nucleo-F401RE



ST Employee

Are you in a live debug session when you try to configure the trace or have you just switched to the debug perspective?

Have you activated SWV in the debug configuration?

Associate II

I was in a live debug session, I was also observing the live expression of the same variable I was trying to plot. I activated SWV in the debug configuration but then "Configure trace" option became deactivated so I reverted it back.

Does this happen with any project you're creating? Do you have another board to test it on?

I haven't been able to recreate the problem myself but I'll give it a try on the Linux computer to see if it's OS specific later today.

Yesterday, I tried again to activate SWV and was able to open the window and configure this time, I don't know what changed from then.

Thanks for your effort.


It is not OS-dependent. In any case at least some feedback to the user is required even if these settings require an active debug session.

btw , from my experience with IDE and SWV : its more like rolling the dice, than a reliable setting .

interesting: when you got it running, it works on this project/debug "always" , when starting debug.

BUT i also have projects, on same boards (ie nucleo-H563zit) with same debug settings, where it never works, no matter, how often i open swv settings and hit the red "start" button. never runs on this projects, but always on same board when debug a project with working swv. So more a kind of a game with unknown rules.

If you feel a post has answered your question, please click "Accept as Solution".
Associate II


is there any solution to this problem?

I tried to configure the trace in every SWV View. But the window does not open. It doesn't matter if I am in an running debug session, a halted session or if I just opened the debug perspective. There is no reaction if I click on this icon.

Please help.

Best regards