Showing results for 
Search instead for 
Did you mean: 

STM32CubeIDE requires, which is not provided on Fedora 37 anymore.

Associate II

I recently updated my Fedora installation to the 37 beta. Because the package `ncurses-compat-libs` which provided the ncurses5 library was removed, I am unable to install STM32CubeIDE.

A fix would be to update the dependency to version 6, which is provided by Fedora 37 by `ncurses-libs`.

Associate II

I had the same problem with Ubuntu 23.10 when I tried installing STM32CubeIDE with, but it installed successfully with the Generic Linux version, My OS uses ncurses6 and STM32CubeIDE is running fine under Ubuntu.

However, the STM32CubeIDE installation is broken! I.e., while I didn't get any errors installing it, I just got one from the debugger! I was able to Build my project, but when I plugged the board with ST-Link and ran the debugger, I got this error:

Could not determine GDB version using command: arm-none-eabi-gdb --version
arm-none-eabi-gdb: error while loading shared libraries: cannot open shared object file: No such file or directory

So, GDB was expecting but I only have! So, it's back to trying to install ncurses5.

Sorry for jumping the gun on this.


For Fedora, try this library as a replacement : ncurses-compat-libs.

For Ubuntu, have a look at this, it is for Debian but should also work.

Associate II

I got my STM32CubeIDE to work under Ubuntu 23.10 by building gcc-arm-none-eabi-10.3-2021.10 and replacing the original STM32CubeIDE/plugins/ with the new one. The build took several hours of machine time on an  i7-5820K with 16 GB RAM. I was too lazy to trim it down to just build the arm-none-eabi-gdb since the configuration was too daunting for me.

Pavel A.
Evangelist III

Ah so it is gdb. I thought it is the cube programmer CLI. Then removing this dependency isn't trivial - but still not a rocket science.


I got the same issue with Debian Sid, libncurses5 does not exists anymore.

Please update gdb build with up to date dependencies. libncurses6 exists in ubuntu since 20.04 (4 years ago).

My STM32CubeIDE installation was running OK on Ubuntu 23 but then it broke; I think it was when I installed the separate STM32Cube Programmer. I found in /snap/core18/2812/lib/x86_64-linux-gnu so I did

sudo vi /etc/ and added the line




 and then sudo ldconfig. That fixed it for me.

Thanks! This work for me"


On Ubuntu 23.04 I encountered the same problem, and `libncurses5` cannot be installed anymore.

New Solution:

`sudo apt install gdb-multiarch`

And then, go to "Window" -> "Preferences" -> "Toolchain Manager" -> "Add Local" and set it up like this:


Then "Set Default" on this new entry.




that worked for me in Ubuntu Studio 24.04 with STM32CubeIDE 1.15 (installed with generic linux installer).

Best regards,



I'm trying to install STM32CubeIDE 1.16 using the rpm installer in almalinux 9.5, but it won't allow it, as it misses on the rpm checks.


I've installed ncurses-compat-lib from epel9 and it includes /usr/lib64/, also the package ncurses-compat-lib provides lists give:

  • ncurses-compat-libs = 6.2-8.20210508.1.el9
  • ncurses-compat-libs(x86-64) = 6.2-8.20210508.1.el9

It provides libncurses but for 64 bits. I found a package packaged for rocky linux with the same version number for i686

i installed it and the stm package finally allowed installation. This means, either st is still dependening on old i686 libraries or that the definition of dependencies of their packages is wrongly pointing to the i686 package.