cancel
Showing results for 
Search instead for 
Did you mean: 

STM32CubeIDE 1.14.1 Marketplace & Install new Software broken

0xcafeaffe
Associate

Hi,

when trying to install new Plugins (e.g. SonarLint) using the Marketplace or via Install new Software Dialog I get the Error: "javax.net.ssl.SSLHandshakeException: Valid cert chain, but no trust certificate found!" (@see attached log file)

I have installed three different versions 1.10.1 - 1.12.0 and 1.14.1 of STM32CubeIDE in parallel on a Windows 10 Machine. I experience the same issue also with STM32CubeIDE 1.12.0. But the STM32CubeIDE 1.10.1 is working fine and I am able to install Plugins there, like I did in the past. It seems newer versions are broken. 

For verification I installed a regular Eclipse for C++ on the same machine and it is also working fine. With regular Eclipse I am able to install new Plugins using the Marketplace or via Install new Software Dialog. I also verified that STM32CubeIDE 1.14.1 Marketplace on Ubuntu 22:04 machine is also not working and produces the same exception and error message.

So it is truly an issue of STM32CubeIDE (newer than 1.10.1) and not an issue of the machine it is running on .

Please urgently fix that issue. Some plugins are mandatory for development.

Kind regards

1 REPLY 1
jacobq
Associate

I do not know exactly why, but I had a terrible time trying to install SonarLint via Eclipse Marketplace as well. I kept getting encryption certificate related errors so finally just downloaded the ZIP directly and performed offline installation.

 

1. Download 

org.sonarlint.eclipse.site-9.3.0.81553.zip (found among All releases)

2. Help -> Install New Software -> Add -> Archive (select ZIP)

3. Restart

 

 

jacobq_0-1709588572578.png

 

See also https://stackoverflow.com/questions/5482554/how-to-install-plugin-for-eclipse-from-zip & https://community.sonarsource.com/t/installation-issue/11158/5