cancel
Showing results for 
Search instead for 
Did you mean: 

STM32Cube IDE 1.12.0. What version GNU Tools from STM32Cube IDE 1.6.1 and how to install them?

Riscy00_UPP
Associate III

I have a client project using Cube IDE 1.6.1, not willing to install Cube IDE next to the already installed Cube IDE 1.12.0, was it possible to downgrade the GNU tool and if so what version to use and how.

1 ACCEPTED SOLUTION

Accepted Solutions
Semer CHERNI
ST Employee

Hello @Community member​ 

First let me thank you for posting.

Under "Preferences"->"STM32CubeIDE"->"Toolchain Manager" you can add the tool chain version you want.

As per your question about the GNU version used with CubeIDE 1.6.0 it's the GNU Tools for STM32 toolchain v9.3.1.


_legacyfs_online_stmicro_images_0693W00000bi5lNQAQ.png 

BR,

Semer.

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

View solution in original post

4 REPLIES 4
dhs
Associate III

You can select any toolchain you want. See picture down below. Using the same version as your client is a good starting point.


_legacyfs_online_stmicro_images_0693W00000bhzEDQAY.png 

Semer CHERNI
ST Employee

Hello @Community member​ 

First let me thank you for posting.

Under "Preferences"->"STM32CubeIDE"->"Toolchain Manager" you can add the tool chain version you want.

As per your question about the GNU version used with CubeIDE 1.6.0 it's the GNU Tools for STM32 toolchain v9.3.1.


_legacyfs_online_stmicro_images_0693W00000bi5lNQAQ.png 

BR,

Semer.

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Riscy00_UPP
Associate III

Thanks, I have it working.

dana_sch
Associate II

I am having trouble with this issue still. The image is not showing up, for starters, so I'm not positive what is being shown. Specifically, I don't seem to be able to install older patches of given GNU Tools versions. I cannot rebuild software that has already been released because the GNU Tools version used for the build got auto-updated out and I cannot find a way to roll it back.

My build requires "C:\ST\STM32CubeIDE_1.3.0\STM32CubeIDE\plugins\com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32.10.3-2021.10.win32_1.0.100.202210260954\tools\bin\arm-none-eabi-gcc".

I only have one revision of v10.3 available, and neither of the ones actually installed match the version mentioned above. Please advise on how to install the old version.