Showing results for 
Search instead for 
Did you mean: 

makefile:##: *** multiple target patterns. Stop.

Associate II

First time on this forum, thought that software would be the place to post...  Closest option for a label that I see.

I get this error after taking a workspace from a windows environment to Linux.  It seems obvious to me that the Makefile is still using the backslash for paths (which I gather the Linux version of the 1.14 STM32CubeIDE does not work).  I get the normal messages about being careful when up in revisions.  I never really ran into problems with the development environment (version 1.5 was my oldest), but I have never tried to use/import an existing workspace from windows to Linux.  Building a new project in the workspace does produce correct Linux file paths.

  • I tried deleting all of the makefiles and .mk from the directory.  I thought that rebuilding the project would generate compatible makefiles (and .mk).  The IDE does generate the files, but they still have the windows path 'types'.

qpcGnuCAN.elf $(OBJS) $(USER_OBJS) C:\Projects\STM32\qpcGnuCAN\STM32F103RBT.....

  • I then tried importing the file from the windows workspace, but same result.
  • Did some searches, no satisfactory answers... so far.

Regards & thanks for any input