Showing results for 
Search instead for 
Did you mean: 

Installation of Cube IDE on ubuntu 22.04

hi there,
I tried to install latest version of the STM32 Cube IDe 1.15.1 of deb file on Ubuntu 22.4. But it showing me that Segger J-Link is being not downloaded. Any suggestions on how to fix the issue?

Below is the error
Errors were encountered while processing:
N: Download is performed unsandboxed as root as file '/home/admin1/Downloads/makeself_dir_Dg5j3M/segger-jlink-udev-rules-7.94h-linux-all.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
E: Sub-process /usr/bin/dpkg returned an error code (1)



ST Employee

Hello @I_am_a_couch_potato 

First let me thank you for posting.

If I am well understanding the situation, you are using the Debian installer on a Ubuntu machine.
This scenario will lead to installation issue.
If this is the case please use the correct installer for your OS.


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

I have resolved this issue temporarily with the help of commands given in another community post in the given link below.
I will try the above solution as well.
Thank you

@Semer CHERNI  - but the Debian installer for a Ubuntu machine is the correct one surely?!? You even state that in the installation guide, document UM2563.

"• PACKAGE is the Linux® package type to be installed. The supported packages are:
– for Fedora®/CentOS
– for Ubuntu®
– .sh for generic Linux®"