Showing results for 
Search instead for 
Did you mean: 

I have wanted to emulate a program based in a STM32F4-Discovery with QEMU, but I obtained the following error message: NVIC: Bad read offset 0xd88 qemu-system-gnuarmeclipse.exe: Attempt to set CP10/11 in SCB->CPACR, but FP is not supported yet. Thanks,

Associate II

Regarding the message error about QEMU unsupported FP, I tryed to set MCU option to Floating Point Unit to none, but some parts of code uses VFP register arguments.


I'm getting the same error and when I searched for it, I found threads dating back to 2015 and no recent threads. In those, there was no FP support and I don't know about now if anyone did anything to add FP support. Also, I find this where it says to disable the hard FP but still no effect. Did you find anything?

Check where the code enables the FPU, might be doing it in SystemInit(), grep the code.

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

Do I need to comment out that section, because if I do so, it gives error that VFP register arguments are being used but .elf file does not.


Don't use PLL