Showing results for 
Search instead for 
Did you mean: 

Debugging with "Autostart local GDB server" not working in STM32CubeIDE v1.15.0

Associate II

Yesterday (03-04-2024) the debugger was running out of the box on the STM32H735G development kit. Today the IDE seems not to start the gdb server at all when starting the debugger the following error is prompted: 


These are the settings:


I already tried the following things:

  • disable the firewall port restrictions
  • start the gdbserver manually from: C:\ST\STM32CubeIDE_1.15.0\STM32CubeIDE\plugins\\tools\bin (find attached the config.txt that I changed with the path of the programmer) and "Connect to remote GDB server". Note: this was actually working but is not the preffered solution in our case.

Any suggestions how to fix debugging with "Autostart local GDB server" ?

ST Employee

Hello @gerbenp and welcome to the community,


To solve this problem, you can do an st-link upgrade and then change the port to 61238 in the debug configuration.

Hope this helps!



Associate II

Hi Rim!


Thank you for your quick response!

Maybe good to mention that yesterday I already sucessfully updated to the latest version of ST-Link as prompted by the IDE (probably when started debugging). It worked perfectly throughout the whole day (did not reboot the PC).

Anyhow, I followed your instruction and downloaded the ST-link upgrade from: . I started the ST-LinkUpgrade.exe tool and the current version match the "Upgrade to Firmware" field:


Ran it again with MCO output to (HSI/2 (8MHz)) and got the following response:


Then I set the port to the proposed port 61238:


Unfortenately, the error (No ST-LINK detected! Please connect ST-LINK and restart the debug session) still remains:



Any more suggestions?


Associate II

Today I got new insights.

I started this project at my home with a Dell 6-in-1 MultiPort adapter attached to my laptop (since there is only usb-C available on my laptop) enabling the internet/LAN connection and ST-Link connection. This descibes the setup that was working via the "Autostart local GDB server".

When I tried to start this project at work while connected to the docking-station, the "Autostart local GDB server" didn't work. Today I had the idea to bring things back to the original (home) situation at work. See picture below:


Bringing it back to the original setup sovled the issue because the debugger started with "Autostart local GDB server"! Might it be caused by the network-adapter? Can this be set somewhere in a config-file?