Showing results for 
Search instead for 
Did you mean: 

"Could not find an STM32CubeIDE installation"

Associate II

When trying 'import a local project', I get a message "Could not find an STM32CubeIDE installation".

I have it installed (D:\Program Files\ST\STM32CubeIDE\1.11.0\STM32CubeIDE), but it's not clear where to set this in the extension settings. Thanks

Associate II

VSCode For STM32 is based on Microsoft Embedded Tools and when it was announced, they wrote "Today our importer requires that you have the STM32CubeIDE software installed in the default location for your platform."

Importing ST projects into Visual Studio Code

If you ignore the error message when you import an existing project, it creates a cmake\gcc-arm-none-eabi.cmake file, where you can see that it looks for STM32CubeIDE in


I solved the problem by creating a ST folder in the root of my C drive and a symbolic link inside that to my STM32CubeIDE installation.

For you, I think this should work if you run it in a command prompt as administrator:

cd \
mkdir ST
mklink /D c:\ST\STM32CubeIDE_1.11.0 "D:\Program Files\ST\STM32CubeIDE\1.11.0"

Interesting, that symbolic link worked? I don't often use those on Windows. Good to know if so.

Note that by default only administrators can create symlinks.

For non-admin users this privilege can be enabled in the security policy (or as a developer feature) but not recommended, see here for more info.

Peter Allnutt
Associate III

Is this ever going to be fixed? I'm just venturing in to the world of VS code and this has caused me some pain. I thought my Cube IDE was installed in the default ( in my case c:\ST\STM32CubeIDE ) but I've still had to create the MKLINK suggested kindly by @Jais

Just for reference STM32CubeIDE has moved on somewhat from 1.11.0 as I'm now rocking 1.13.1