Showing results for 
Search instead for 
Did you mean: 

Unable to connect to STM32H7 devices

ST Employee
After re-programming STM32H7 device, I can’t connect to the device. Connect under reset doesn’t help. Why?

There are two possible root causes, that can cause this issue. First one is more probable and is related to power supply misconfiguration. And second to configuration of boot process in option bytes.

Possible root cause 1 (power supply misconfiguration)

This applies to all STM32H7 devices with configurable internal SMPS step-down.
This is most probably related to power-supply configuration. STM32H7 devices with embedded step-down converter offer different power-supply schemes. The selected configuration depends on external components.
This configuration can be set only once after power-on reset. Choosing wrong configuration leads to MCU lock-up. The configuration is done with the following line in HAL library (usually placed in SystemClock_Config function):
Most of the boards have the supply directly from SMPS (if available in MCU), which requires the above function to be called with PWR_DIRECT_SMPS_SUPPLY parameter. But STM32CubeMX generated projects might have PWR_LDO_SUPPLY option by default. Also the PWR_DIRECT_SMPS_SUPPLY option is available in version 5.4.0 and older.
Since the configuration can be changed only once after power-on reset, the issue might manifest itself after next power cycle.
Below is diagram from reference manual showing different hardware configurations for power supply.
The MCU contains protection mechanism that prevents setting higher voltage from internal SMPS to VCORE (1.8 or 2.5V). This should prevent damaging the MCU due to misconfiguration.


Since the power-supply is usually configured immediately after reset, it is difficult to connect during that short window.
Solution 1 is to:
  1. Plug the board to power supply, while the reset button is being held low (or NRST pin in general).
  2. Keep the reset button low.
  3. Connect via STM32CubeProgrammer. When the program starts connecting, release the reset button. Although this requires quite precise timing, it should be easy to achieve.
  4. Perform mass erase.
  5. Make sure that you fixed the power-supply configuration in your project.
Solution 2 is to:
  1. Plug the board to power supply, while the BOOT0 pin is being held high. This requires the BOOT_CM7_ADD1 to be set to system memory.
  2. Keep the BOOT0 button high.
  3. Connect via STM32CubeProgrammer. The system bootloader shouldn’t touch the power-supply configuration. However it will configure the pins related to bootloader communication interfaces and might disturb external components on the board (this might be critical for custom PCBs).
  4. Perform mass erase.
  5. Make sure that you fixed the power-supply configuration in your project.

Possible root cause 2 (Cortex-M7 boot disabled)

This applies to all STM32H7 devices with dual-core feature.
Other possibility is that the option bytes are configured in a way, that only Cortex-M4 boots after reset (BOOT_CM7/BCM7=0, BOOT_CM4/BCM4=1). Then you need to connect the debugger to Access port 3 (Cortex-M4), instead of Access port 0 (Cortex-M7).
In current STM32CubeProgrammer version (2.2.0 and older) this seems to not work. Please use ST-Link Utility instead, or update STM32CubeProgrammer (when new version is available).
For development it is recommended to keep booting from both cores enabled, otherwise some tools/IDEs might not be able to work with the device.
Customer Note:
1) You can contact the author of this article by clicking on name provided as “Created By” info.
2) All other comments or feedback you can post by email to
3) If you need specific (product) support please refer to our Support Center( where you can choose from a variety of online support options and select a service which fits your requirements best.
Senior II

@Adam BERLINGER​ Thanks a million, this made my day! I thought I bricked my board. In fact, I tried STLink Utility and I came across those different ports, but I was just afraid to give them another shot! This article saved me and my board is back to life again!


Hello @Adam BERLINGER 

Thank you for your post. I want to run Nucleo-H745 board with maximum frequency which is 480 MHz. For this, it was required to change voltage scale to 0 and enable either PWER_LDO_Supply or PWR_EXTERNAL_SOURCE_SUPPLY. I tried with both the options to load the controller, but found error as target not responding.

Could you please suggest correct configuration so that I can operate the borad with 480 MHz for M7 and 240 MHz for M4.

Thanks in advance.


ST Employee

Hello @Nsg1987,

To use LDO on Nucleo-H745, you need to do HW modifications to the board and also add some additional VCAP capacitors. I think the user manual should provide more information on how to do this, but it might not be trivial task.

Best regards,



Hello @Adam BERLINGER 

Thank you for your reply. I have gone through the manual and found the same.

/* Exported types ------------------------------------------------------------*/
/* Exported constants --------------------------------------------------------*/
/* Set this define to 1 to OverClocking the system clock to 480MHz*/

Over clocking the system clock to 480MHz is only available with LDO PWR configuration
by default The NUCLEO-H745ZI-Q board comes with DIRECT_SMPS configuration
in order Over clock the system clock to 480MHz to the nucleo board must modified
to change the PWR path to LDO instead of DIRECT_SMPS

to do so please change the following solder bridges :
- LDO config :
Mount : SB25, R33(0R), SB74
C58 & C54 = 2.2uF instead of 100nF
Removed : SB92, SB79, R35(0R), SB75, SB76

- Direct SMPS config (default config):
Mount : SB92, SB79, R35(0R), SB75, SB76
C58 & C54 = 100nF
Removed : SB25, R33(0R), SB74

Note that the Board HW configuration must match with the FW config
if not will face a deadlock (can't connect the board any more)
the FW PWR configuration correspond in the main.c to the following :
Function SystemClock_Config :
- case of LDO config : HAL_PWREx_ConfigSupply(PWR_LDO_SUPPLY);
- case of Direct SMPS config : HAL_PWREx_ConfigSupply(PWR_DIRECT_SMPS_SUPPLY);




Version history
Last update:
‎2019-10-17 12:17 AM
Updated by: