Showing results for 
Search instead for 
Did you mean: 

How to disable any kind of polling in SED devices?


Dear all,

I am happy playing with STM32WB kits but there is something that really annoys me.

I am creating a very low power temperature sensor configured as SED. The problem is after every payload I send it stays in fast polling every 500 ms for some time. This drains the battery. As it is only a temperature sensor I never expect to receive commands so I do not need any kind of polling. How can I permanently disable it?


Looks like Zigbee_OnOff_Client_SED works as intended using anothe STM32WB as coordinator. Power consumption in stop2 is as expected around 3uA.

If I use another device such as zigbee2mqtt or xiaomi gateway it has a different behaviour. After sending a command it generates 6 poll requests and after that CPU2 is not going to STOP2consuming 1.8mA.

The point is that right after transmitting it goes into stop2 but around 1 second after it wakes up and stays up until next transmission.

Is there any way to avoid waking up too early?