Showing results for 
Search instead for 
Did you mean: 

Custom BLE Server Issues with Custom Hardware and STM32WB35

Associate II

Any advice on where to start to track down an issue related to a custom BLE server not functioning on custom hardware? I am using the STM32WB35CEU6A and have flashed the firmware and wireless stack as well as followed this guide: CubeMX Initialization (of course changing the hardware configuration to match my custom hardware). I understand this guide is catered towards the STM32WB55, but I cannot even see the BLE server on my peripheral devices. 

I have tried the debugger to track down the issue, but it just loops through UTIL_SEQ_Run(UTIL_SEQ_DEFAULT);

Any advice on how to proceed? Is there a way to debug the other core? Where can I put a printf() to check that the BLE application is running smoothly, to confirm that the issue is not hardware-related?

Thank you!


ST Employee

Hello @RCM1 

I suggest you start on our Nucleo-WB55. If everything works fine, use the AN5811 and the AN5805 to migrate the project to your STM32WB35CEU6A based design. Also, you should ensure that your design is verifying the recommendations of the AN5290.For Debug recommendations, look at this presentation.

Best Regards.


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.