cancel
Showing results for 
Search instead for 
Did you mean: 

TouchGFX documentation feedback

Romain DIELEMAN
ST Employee

We wish to always improve our documentation. The best reviews and critics always come from the people that read it, so we would like to use this post to collect your thoughts and feedbacks.

Please share what you like, dislike, what you think is missing, etc ...

/The TouchGFX team

29 REPLIES 29
wired
Senior III

The written documentation is quite good. There may be some areas where additional explanation/rationale for using a particular widget would be helpful. What I would like to see most, however, is written or video tutorials on how to take a TouchGFX Designer project and use it in STM32CubeIDE, EWARM, etc. I am so far unable to do so successfully, so it is apparently not as simple as, for example, opening up the Project workspace file under the EWARM folder, or opening the .project file for STM32CubeIDE.

GBert.2
Senior

Adding common strategies/design patterns to propagate information from and to the model would be interesting.

For example:

Michael K
Senior III

I'm still having this issue where if I search and land on a class reference page, all the further links I click on the page 404 until I refresh. It's honestly pretty annoying and has been present since the documentation pages were released :(

Also, most google results point to previous versions of the documentation. Maybe you should have a single canonical "current version" URL path (e,g. support.touchgfx.com/latest/docs/..., and have different paths to the previous versions that are ignored by google so that google searches always lead to the latest version (e.g. support.touchgfx.com/archive/4.15/docs/...).

Hello Michael,

Could you share your browser again ? We thought this was fixed so it is bad news to hear that 😅 (tried to replicate it myself just now with Chrome 93.0.4577.63 but it worked fine).

I'll forward the comment on the "current version" URL path as well 👍 It makes sense.

/Romain

Welp, I figured I'd make sure I was fully up-to-date before replying, and seems like Brave Version 1.32.115 Chromium: 96.0.4664.93 (Official Build) (64-bit)

the problem is fixed. I swear it hasn't been THAT long since I last updated! 🙂 Sorry about that.

However while I was checking this I noticed that a lot of API Reference results aren't being returned by the search bar. For example:

0693W00000Ho3iiQAB.pngThe result points to the user manual page for the Dynamic Graph:

0693W00000Ho3gOQAR.pngWhen there should be a result directly pointing to the API reference. I know this functionality existed before.

By the way, are you getting notifications for ST Community replies? I thought I used to get emails and bell notifications on the top of the St community page, but I didn't get either for your reply.

Michael, I got your post via email.

Thanks @wired​ 

Weird... I didn't get your reply notification either. I checked my notifications setting and everything looks right.

@Romain DIELEMAN​ I just had it happen again, but when I went to screen record it for you, it stopped happening... :(

This time I was for sure up to date when it happened:

Chrome is up to date

Version 96.0.4664.110 (Official Build) (64-bit)

This bug still occurs, but I'm not sure how to reproduce it...