cancel
Showing results for 
Search instead for 
Did you mean: 

STM32H563 Regression not working after standart provisioning through STM32CubeProgrammer

gustavo_vintacourt
Associate

Hello, I'm using the STM32H563 and performed a standart procedure to change the product state, perform provisioning and change the product state to closed, all through standart provision operation with the STM32CubeProgrammer for the first time working with this core.

It worked, the product lost interface with the debug, I can't read it's flash memory through the software, but it's failing to perform the debug authentication and full regression of the processor to OPEN product state again.

I tried running the discover command in STM32CubeProgrammer, tried with the regression.bat batch file of an example application (https://wiki.stmicroelectronics.cn/stm32mcu/wiki/Security:How_to_start_with_DA_access_on_STM32H573_and_H563-TrustZone_disabled_-_stm32mcu) and nothing is working.

I'm using a STLINKV2 and tred all possible combination of configurations of it, updated the STLINK firmware with the STM32CubeProgrammer. The closest I got to performing the regression is in these screenshots and attached files, the problem appears to be in DBGMCU Mailbox.

Discover with STM32CubeProgrammer:

gustavo_vintacourt_0-1717511849755.png


Running regression batch file in example project folder:

gustavo_vintacourt_2-1717512074732.png

Running regression batch file with windows + run command:

gustavo_vintacourt_1-1717512033618.png

If anyone had this problem and managed to fix, please let me know. Thanks in advance

 

1 REPLY 1
Jocelyn RICARD
ST Employee

Hello @gustavo_vintacourt ,

you should connect the reset pin to your STLinkV2 otherwise authentication is not possible.

Best regards

Jocelyn