Showing results for 
Search instead for 
Did you mean: 

Firmware download via Y-Modem crashes with the following error when selected in UserApp example project "!!Error during file download!!".

Pascal Seiz

Hello guys I hope you can help me with my problem regarding my adaptation of sbsfu.

I'm currently adapting the stm32f413h-discovery example project on a stm32429zi. Everything works fine with one mayor exeption. I have difficulty downloading a new firmware version via Y-Modem. Everytime I want to downlaod a newer version (e.g. changed version nr. in postbuild.bat and in userapp.c) the download crashes and I get the following output via terminal. (all securities where off during testing)

_legacyfs_online_stmicro_images_0693W00000bj8nsQAA.pngI can however download the firmware successfully when holding the userbutton on a reset like it is mentioned in um2262 chapter 8.4.

I have tested this with multiple version numbers, all have worked.

I also tried activating securities and then using the user button, but in this case a button bush is considered a "Tampering fault".

_legacyfs_online_stmicro_images_0693W00000bj8oWQAQ.pngI have also figured out that both methods (download in sbsfu and download in userapp) use completly different functions. I'm not familiar enougth with how Y-Modem works to find any helpful differences between those functions that could lead to such an error.

I have listed my hardware and software I'm currently using , hopefully it helps.

Hw & Sw I'm using:

  • Windows Ver. 10.0.19045 Build 19045
  • TeraTerm Ver. 4.106
  • SBSFU Ver. 2.6.2
  • CubeIDE Ver. 1.11.2
  • STM32F429ZI
ST Employee

Hi @Pascal Seiz​,

can you please try getting an older TeraTerm?

I personally use version 3.84. I believe later versions modified their approach to variable block length and that is not supported in the SBSFU implementation of the YMODEM.

If that doesn't help, let us know and we'll try to investigate further.



To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Hi @JHOUD​ thanks for your reply.

I got an older version of TeraTerm, version 4.8.3 because I couldn't find any version with a starting 3. So i guess it was a typo in your last answer.

Well updating a new firmware no more ends suddenly in an error message. Unfortunately I'm stuck at package 2 when trying to transfer a new firmware.

I know the file transfer needs a few seconds after the first package to validate the firmware header, but what suprises me is the following.

The upload is stuck at package 2 but I can see the user led (the default green one) toggles after around 2 seconds after I pressed "send" in teraterm.

The program clearly exited the y-modem receive loop and returned to the main loop where the green user led is toggled.

I have researched some other posts with y-modem difficulties but couldn't find any meaningful similarities.

Can this be caused by misconfigured option bytes or by the validation of the firmware header?

Kind regards,


Can be related: a similar note about using older Teraterm is in the EMW3080 firmware update appnote. but there the old good version is 4.85; new versions are 4.100+.