Showing results for 
Search instead for 
Did you mean: 

Unable to Connect to a Custom H725RGV6 Board

Associate II

Hi all, recently I made a board with H725RGV6, but when I tried to flash a test firmware for the first time, I got " Error: No STM32 target found! If your product embeds Debug Authentication, please perform a discovery using Debug Authentication" from STM32CubeProgrammer (I'm using STLink V2). 

I measured the power supply and VCAP, VDD looks good at 3.1v, but the VCAP is only 100mv which is not correct. I also tried to remove the third 2.2uF for VCAP and connect PIN66 to PIN49, so VCAP is around 80mv.

- I've checked the orientation.

- I soldered the chip with a 700F heat gun and tried 3 chips in total.

- Updates: I tried to supply 1.2V to VCAP, then I can connect to the chip. But why? Shouldn't the chip have internal LDO?

Below is the power supply part schematic. Does any one have any suggestions?




Accepted Solutions
Associate II

Finally found the issue, the H725RGV6 package doesn't include the internal LDO.

View solution in original post

Senior III

Just thinking...

You have a chip with SMPS - but you do not use it (VDDSMPS is GND). Not sure, I would expect: when a chip with SMPS (the Q version) - provide the 2.2microH coil and let "use" SMPS (if it is not an LDO bonded chip version).

Another issue could be:
What is the header pinout for your debugger?
The debugger wants to see the VDD of the target: if you do not provide VDD on debug header - the debugger might "think": "there is not a target connected. And debugger needs also VDD from target in order to "adapt" the debug voltage levels. Without VDD to debugger - it fails.

My debug header for ST-LINK looks like this:


If the debugger does not find VDD (or the GND via this 100R) - it might assume the target is not connected.

Hi tjaekel, thanks for your reply.

1. In the AN5419, it says "On STM32H723/733, VDDLDO is not available on a pin/ball. It is internally connected to VDD". So I assume it's the same for the STM32H725RGV6 since there is no VDDLDO pin on the chip. I found most people don't use the SMPS and they all work fine, so I also didn't use it.

2. I've provided the VDD for the debugger. However, the main problem seems to be the chip not booting up correctly since the VCAP is low.

Associate II

Finally found the issue, the H725RGV6 package doesn't include the internal LDO.