Showing results for 
Search instead for 
Did you mean: 

STM32H573I-DK stuck in EMW3080 firmware update utility



I have a STM32H573I-DK and I tried to update the firmware of X-WIFI-EMW3080B as described in the package "WiFi firmware update for MXCHIP EMW3080B on STM32 boards" downloaded from

When I'm connected over the ST-LINK USB connector and start the serial terminal (115200, 8N1) I see the following messages and prompt:

################### Welcome to EMW3080 firmware update utility 1.1.0 for board RevA  ###################
STM32> Configured for MXCHIP embedded FW ST-EMW3080B_V2.3.4_SPI.OTA.BIN 0x800024c / 686672 bytes
STM32> Push the user button (Blue) to program the EMW3080 device or enter command
STM32> MCU system clock 240 MHz, Uart Baud rate 921600, Software emulated UART bit duration 260 cycles

"      help"            print this message
"      boot"            boot EMW3080 (needed before using mx command)  
"        mx"            mx [cmd]: send command to mxchip device (cmd which requires ymodem protocol can't be used)
"     flash"            flash mxchip firmware (same as pushing the blue button)
"     check"            check mxchip firmware

Resetting the board does not help, it returns to the same prompt. Also, none the commands seem to work, e.g. typing help does not display anything, the system seems stuck.

Is there any way to restore the board to the factory functionality, i.e. running the demos it was shipped with?

Thank you.


Guillaume K
ST Employee


The STM32H573I-DK demo software binary is available on web site, on the the board's page, in Tools and Software tab:

STM32H573I-DK - Discovery kit with STM32H573IIK3Q MCU - STMicroelectronics

look for "Binary resources" section, "Compiled demos".

direct link:

you can program it with STM32CubeProgrammer


Guillaume K
ST Employee

Regarding the WiFi firmware update: before running the firmware, did you plug the MB1400 EMW3080 board to the STM32H573I-DK STMOD+ connector (CN3) ? (with MXCHIP chip facing "up")

Hi Guillaume,

Sorry for the delay.
Yes, I had the module plugged in properly. I managed to recover the board by compiling and flashing one of the demos. I also tried the Nx_Network_Basics_wifi example to test the WiFi module and it worked, which indicates that the WiFi FW upgrade succeeded.
Further experimentation showed that the serial connection settings and application are important when using the EMW3080B FW update utility. I had success with the commands of the aforementioned  FW update utility by using picocom (Linux)

picocom -b 115200 -p n -d 8 -s 1 --imap crlf --omap crlf --emap crcrlf,delbs /dev/ttyACM0

However, I still need to flash some other application to replace the FW utility.

Thanks for the link to the original STM32H573I-DK demos.