cancel
Showing results for 
Search instead for 
Did you mean: 

STM32F769NI - Discovery, Issue Displaying Pictures on LCD Saved on SD Card

amattes
Associate II

I recently purchased a STM32F769NI MCU Discovery Kit. The kit is brand new, and I was looking to run the example display application "LCD_PicturesFromSDCard" from the most recent version of STM32CubeF7 software package. I downloaded the most recent version of STM32CubeF7 (1.17.0) as well as the most recent patch (1.17.1). I compiled the "LCD_PicturesFromSDCard" project in Keil uVision5 changing the optimization level to 0 and changed the defined processor symbol from "USE_STM32F769I_DISCO" to "USE_STM32F769I_DISCO_REVB03".

 

As instructed via the readme.txt for this specific example application, I created a "Media" directory under the empty micro SD card root, and copied the 5 .bmp images provided in the sample application to the micro SD. I then connected the micro SD to the STM32F769NI MCU Discovery Kit and tried to run the application to display the photos with no success. The error of no bitmap files is consistently debug outputted to the display. I repeated the process using a micro SD from a different manufacturer, still with no success.

 

I tried altering the name of the media file, putting the files directly at the root, changing the example from the cub to look in different folders/places/the root of the SD card, but kept running into the same issue. I also noticed that the SD card never seems to mount correctly, it never identifies any files or folders when loaded using the example when inspecting via debug.

 

Does anyone have any insight into this issue/has anyone had to fix this before? Is this a common issue? Looking to gauge if similar issues have been observed in the past, or if I am missing something during set up. Thank you.

7 REPLIES 7
KDJEM.1
ST Employee

Hello @amattes and welcome to the Community 🙂,

Which Keil version are you using for compilation?

I made some tests for LCD_PicturesFromSDCard project using:

- Keil 5.38.0: I noted a build error, which I reported internally.

-STM32CubeIDE 1.15.0 and IAR: the project works correctly without any issues.

Could you please try with STM32CubeIDE or IAR toolchain and let me know if the issue is solved or not?

Internal ticket number: 180613 (This is an internal tracking number and is not accessible or usable by customers).

Thank you.

Kaouthar

pro-msUwvtRg.jpeg

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Hello Kaouthar,

 

I was originally using Keil V5.24.2.0.

 

I attempted to build the LCD_PicturesFromSDCard project in IAR EW for Arm 9.30.1, and STM32CubeIDE 1.15.1, and successfully built in both IAR EW and STM32CubeIDE.

 

Upon connecting to the STM32F769NI MCU Discovery Kit and running the application with both IAR EW and STM32CubeIDE, I was met with static displayed on the screen (please see attached image).

 

Have you seen a similar error in past troubleshooting? What was the build error you observed in Keil 5.38.0? What version of the STM32CubeF7 software package were you running to successfully display an image?

 

Thank you.

ScreenStatic.png

Image looks to be random frame buffer.

Make sure SDRAM is started and cleared.

Check .BMP files supports (resolution / colour depth) by the application

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

Hello @amattes ,

I'm successfully run the LCD_PicturesFromSDCard example which is in STM32Cube_FW_F7_V1.17.1 package with STM32CubeIDE 1.15.0 toolchain.

The static display issue is detected in STM32Cube_FW_F7_V1.17.0 and solved in STM32Cube_FW_F7_V1.17.1. Please take a look at this post.

Could you please check if the nt35510 drivers are available in your example.

KDJEM1_0-1715759365800.png

I observed this error when I build LCD_PicturesFromSDCard example using keil 5.38.0:

STM32F769I-Discovery\Exe\Project.axf: error: L6047U: The size of this image (39768 bytes) exceeds the maximum allowed for this version of the linker Finished: 0 information, 0 warning, 0 error and 1 fatal error messages. "STM32F769I-Discovery\Exe\Project.axf" - 1 Error(s), 0 Warning(s). Target not created.

After checking internally, I noted that this error is due to MDK-ARM project is configured to build with compiler v5, and MDK-ARM 5.38 comes by default with AC6 only. To use the MDK.5.38 with AC5, it must follow the steps available in this link: https://developer.arm.com/documentation/ka005073/latest/"

It is mentioned in STM32Cube_FW_F7_V1.17.1 Release_Notes that the MDK-ARM development toolchain and compiler version used in this package is V5.31.

Thank you.

Kaouthar

 

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Kaouthar,

The nt35510 drivers are available in my example. Please see below screenshot. Screenshot is from IAR EW for Arm 9.30.1

Screenshot 2024-05-24 105509.png

I am still outputting static to the display. Could it be that the right target hardware is still not enabled somehow?

Thank you,

Alex

Kaouthar,

Following up I have still not been able to resolve this issue. Are there any other troubleshooting methods I should try that relate to enabling the correct target hardware?

Thank you,

Alex

KDJEM.1
ST Employee

Hello @amattes ,

Are able to run any LCD example STM32CubeF7/Projects/STM32F769I-Discovery/Examples/LCD_DSI at master · STMicroelectronics/STM32CubeF7 · GitHub?

Please make sure that you used "USE_STM32F769I_DISCO_REVB03" in defined symbols.

KDJEM1_0-1718210143429.png

I'm using  IAR EW for Arm 9.20.4 toolchain.

Could you please try to download the LCD_PicturesFromSDCard example using STM32CubeProgrammer and .hex file in the attachment.

KDJEM1_1-1718211345608.png

I hope this help you.

Kaouthar

 

 

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.